Jump to content
PayPal donations: [email protected] ×
scram69

E6230 Freezing following sleep after 10.15.5 update

Recommended Posts

Following the update to Catalina 10.15.5, my E6230 is experiencing frequent freezes (requiring holding the power button to restart).

I noticed Herve's comment for this update about the cpu-specific SSDT, but I had already generated that and put it into EFI/Clover/ACPI/Patched.

I also have the SSDT-PNLF.aml from Jake's guide in there as well - do I still need that?

I'm running Clover r5118

I've attached my debug file.

 

Thanks in advance for any advice-

 

debug_28499.zip

Share this post


Link to post
Share on other sites

You have a kinda of hybrid configuration with conflicting settings: for instance AICPUPM patch + generated CPU-specific SSDT but also KernelPm patch and no dropping of CpuPm/Cpu0Ist SSDT tables. You need to chose which CPU power management method you want to use because it's either/or, not a mix of them.

Share this post


Link to post
Share on other sites

Hi Herve,

 

Thanks very much for the reply.  It's been a while since I reviewed my power management settings.

 

I realized that instead of dropping specific SSDT tables, I was setting DropOem=true, which is only recommended for SandyBridge and older CPU's.

 

But I have two follow-up questions if you wouldn't mind helping me a bit more:

1) RehabMan's "generic" HD4000 1366x768 config.plist also drops Cpu0Cst and ApCst.  What about those two?

2) I did not think I had the KernelPm patch enabled as it is both unchecked and "greyed out" in Clover Configurator. RehabMan only recommends it for Haswell and later.  But sure enough, when I open config.plist in a text editor, KernelPm is set to /true.  Is this a bug in Clover Configurator?  Should I just edit config.plist by hand and change /true to /false?

 

Thanks again-

Share this post


Link to post
Share on other sites

Absolutely no need to drop those 2 x tables.

KernelPm patch is now enabled by default in Clover. If you don't use XCPM, it's irrelevant and so, does not matter.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...