Jump to content

Dell XPS 13 9343 Mojave sound and bluetooth issue


linuxchan6
 Share

Recommended Posts

I have a XPS 13 9343 with a 4k display and a DW1560 wifi card.  Installed Mojave with wifi working; but not able to get sound and bluetooth to work. I've checked the usb tab in Hackintool and it doesn't seem to recognize any internal device attached.  I have attached debug file and any help is appreciated.

debug_2627.zip

Link to comment
Share on other sites

I removed SSDT-UIAC.aml and tried the attached config.plist, but couldn't boot to desktop. Please see attached boot error.   I had to remove Root->Devices->PciRoot(0x0)/Pci(0x2,0x0) in order to boot to desktop.  But still couldn't see bluetooth nor audio device.

IMG_0242.jpg

Link to comment
Share on other sites

  • Moderators

try different layout-id for audio

3, 13, 23

 

For Bluetooth, make sure your USB ports are configure correctly. Check under system information/USB if your Bluetooth device shows up.

Use Hackintool.app to assist you with setting up the USB ports correctly

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...