Jump to content
PayPal donations: [email protected] ×
mefflecakes

Optiplex 5040 - Intel HD530 graphics: can't get DisplayPort output

Recommended Posts

Ok, so I remembered the server in the cupboard under the stairs is a 7040, so I tried using @Jake Lo's config and it worked first time 👍👍

 

The very last thing I'd like to ask is related to the unplugging and plugging in any video cable, I lose image but when I plug the game back in it doesn't ever come back. Is thanks config related or something I just need to live with? The reason I ask is that I have a display port switcher box and if I don't have the monitor using the correct cable, I have to hold the power button to turn it off, then turn it on again..

Share this post


Link to post
Share on other sites

@mefflecakes, Mario and I played on his Skylake Optiplex 7050 (i5-6600 CPU) with HD530 graphics. We 1st got HDMI + DP working with standard SKL platform-id 0x19120000, then HDMI+DP+DP, i.e. 3 x displays after injecting 4th connector 0306...

 

Secret was to bypass restrictions imposed by AppleGraphicsDevicePolicy kext (a PlugIn of AppleGraphicsControl kext) with boot arg agdpmod=pikera. All details posted here.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...