Jump to content

E7450 OC Big Sur Installation help


Recommended Posts

I made a clone of a working Big Sur,

It works after like 10 restarts; sometimes it loops, but usually i get stuck at these screens. Not sure what i did wrong. I’m using Jake Lo’s efi file, plus i also installed this; (And disabled SIP for it to work) https://github.com/chris1111/Wireless-USB-OC-Big-Sur-Adapter

 

the reason i use gensmbios is bc i'm using different apple id's on each clone.

 

I added me efi to check out. is it the adapter kexts/plugin that is messing things up? thanks

6FB0A2F4-FFB5-47F5-B9F7-3120AE75C05D.jpeg

FB2E9928-BE05-41BA-901D-047DFBD47BC8.jpeg

C0BC146B-EEDE-4D2D-B1AF-EABCA768D036.jpeg

EFI.zip

Link to post
Share on other sites

Gotya! TY!  So i will have to take off; AirportBrcmFixup, BrcmBluetoothInjector, BrcmFirmwareData, BrcmPatchRAM3 when i'm using and RtWlanU & RtWlanU1827 from Wireless USB OC Big Sur Adapter-V6.

 

I wish there was a way to have both these kexts working in conjunction. If i free gift a hackintosh to someone, i would like to have an backup (external usb wifi) way of accessing internet for them, if the wireless adapter ever disconnects and without having to change the EFI.

 

BTW, the Internal and USB wifi sets of kexts both worked together (mac boots consistently without issue) on the original build (with internal wifi/bt card installed) and not on the clone drive (used on an e7450 without a wifi card installed), which takes 10+ restarts/loops to boot properly.

 

I made a discussion topic on the plugin page to hopefully see about finding a fix also: https://github.com/chris1111/Wireless-USB-OC-Big-Sur-Adapter/discussions/22

edit: plugin developer says just take off AirportBrcmFixup when using the plugin

 

Thank you!

Link to post
Share on other sites

Would anyone have any idea why the installer restarts around 60-70% of the progress? Boot's fine to installer, but around 15-20 minutes in, it just reboots. There's something on the installer log, but it's too fast to tell (researching right now if i can find a log somewhere).

 

Certainly it's crashing somewhere as there's no macOS drive showing up on OC as it usually does after a successful install.

 

Running on the 0.6.4 Package from the Main Thread. 

Link to post
Share on other sites
  • Moderators

Usually take 2-3 reboots before completion. 

After system reboots, at the OC picker, make sure to select the new option...Install MacOs..something, not the USB installer.

Link to post
Share on other sites
  • Moderators

make sure to format the drive at the root to GUID / Extended Journaled. Sounds like it's not detecting the drive after reboot

Do you have HFSplus.efi in the drivers folder?

Link to post
Share on other sites

I wouldn't be surprised at any uncommon issues, this is another attempt to install on a WWAN SSD, similar to my 7470.

 

PS, can you elaborate GUID / Extended Journaled? I was able to format the drive in Disk Utility to APFS without any issues, but i used only APFS.

 

Also, yes, HFSPlus.efi is there, as i said, it's your package from the main thread with non-bcrm Wifi and ITLWM added.

Link to post
Share on other sites
  • Moderators

Make sure you disk is formatted to GUID, not MBR. In order to do that, you need to select from the root of the drive, not Volume

  • Like 1
Link to post
Share on other sites

So i found some time to come back to this.

 

Apparently, i've hit of what seems to be known as the 12 Minute Remaining issue on the installer. Seems to even affect real mac hardware. Unfortunately, none of the tips i found worked for me.

 

I can confirm these things:

  • I am using your 7450 OC 0.6.4 Package. Modified to omit AirportBCRM patches/kext under kernel. I havent added the ITLWM yet as i am planning to do that in post-install.
  • BIOS settings are intact as instructed. Updated on the last BIOS too.
  • SSD is being formatted to APFS with GPT Layout (havent used MBR's for ages).
  • OC boots the installer just fine, Disk Utility does the above process flawlessly.
  • The installer goes for about 10 minutes, and it gives me a few errors on the installer log. But it will always restart at 12 MINUTES REMAINING.
  • I went further and tried booting the installer 3-4 times again, but to no avail, it restarts the installation, it does not continue.

Here are some Installer Logs and system verbose logs, but i have no clue if they're in order. LINK (you can ignore the first image with the log, as that is probably macOS not liking its NTFS neighbours).

 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...