Jump to content

D630 Freezing Problem


seb3
 Share

Recommended Posts

Hi, just got my D630 and have been trying for the last 6 hours to install Lion.

 

I managed to apply the bootpack, and install lion. I used myhack, and during install chose generic extra folder.

I then reboot and it boots up lion. It then hangs/ freezes either while loading or during initial setup - most annoying!

 

I have tried different extra folders but they give me KP.

 

Which extra folder do I use of a D630 Nvidia, and how do I stop the freezing?

 

Help much appreciated!

 

Seb

Link to comment
Share on other sites

  • Administrators

Dear seb,

 

You need to use the bootpack for your model and graphics. Use myhack from the usb installer to install the Extra folder. After that, you need to run myfix full mode on the os x partition before rebooting into it.

 

After you got your basic system running, download and install EDP 2.2 to configure your internet connection. After that, download and install EDP 3.1 to improve system stability and performnace.

 

Cheers!

Link to comment
Share on other sites

Hi, I did EXACTLY as you said, and it KP's on boot. Here are a few things I picked out from the KP that might help:

 

error: failed to open PCI device

panic

Kernel extensions in backtrace: VoodooHDA

dependency: IOAudioFamily

dependency: IOPCIFamily

 

Thanks for the help so far!

 

Seb

Link to comment
Share on other sites

Problem solved!!!!!! I now have lion working, wifi battery, screen, graphics, sound, trackpoint, trackpad, keyboard and sleep with sleepenabler.kext.

 

Works wonderfully, I am going to write a tutorial/video on the install process as I dont think its covered in much detail on here.

 

Thanks again,

 

Seb

Link to comment
Share on other sites

yes you could add this -

 

I had to slightly modify the bootpack provided here to get lion to boot without a KP.

 

All I had to do was delete VoodooHDA, then select use your own extra folder during setup. Point it towards the modified bootpack, and wait for it to finish. It then boots fine, without freezing.

 

I then plugged in a usb keyboard and mouse for the initial setup. I downloaded EDP 2.2 and configured it for my model, easy. I rebooted.

The first time you reboot after EDP install, it hangs on PCI Configuration Begin. To get past this, simply hold down the power button and do a manual restart. It then loads up with everything working. To get sleep wokring I just installed sleepenable.kext.

 

Thanks,

 

Seb

Link to comment
Share on other sites

Just updated to 10.7.4. It then would hang on PCI Configuration Begin. I managed to fix that by replacing a few kexts in Library Extensions. It then booted fine but I have lost wifi. Do I need to rebrand the card? I started a new topic asking about it.

 

Thanks,

 

Seb

Link to comment
Share on other sites

Hi, I found out that during the 10.7.4 IO80211.kext was completely removed for some reason. I copied one from my hackintosh desktop and installed it on the D630 and it wokred fine again! I also made a new post with the complete quide for others to use!

 

Thanks,

 

Seb

Link to comment
Share on other sites

 Share

×
×
  • Create New...