Jump to content

[solved] Latitude 5400: LCD brightness, DP and HDMI not working


Go to solution Solved by ryuu_nami,

Recommended Posts

  • Moderators

I have a guide for that here to find the value.

Yes it can be risky, it's been known to have brick some but I have yet to encounter for any of the systems I had hacked personally from Broadwell up to Skylake.

E7450, E7270, E7470, Precision 5510, Precision 7510 and usually a BIOS reset will restore it to default. But it's up to you, I can't take any responsibility if it does for your model.

You can research more if there are other ways to achieve 4k, I personally don't own any 4k display to test.

Link to post
Share on other sites

@Jake Lo 

I've done the bios work and I just can't get into windows and macOS. I attached the screenshot. I've tried setup_var 0xA10 0x3 and setup_var 0xA10 0x2 both of which

give me the same result.  No access to either windows and macOS. I have to change it back to 0x1 to get back in macOS. I think I've done the right thing. It seems like the bios has some protection mechenism or checksum check or md5 check. It keeps give me error when trying to modify it. Any ideas? Does it mean I've came to a dead end? Thank you!

 

 

IMG_6612.jpeg

IMG_6613.jpeg

IMG_6614.jpeg

Link to post
Share on other sites
  • Moderators

after the DVMT is set, you might need to disable these in the Config file, just place # in front to disable

framebuffer-fbmem

framebuffer-stolenmem.

and maybe -cdfon in boot arg

Link to post
Share on other sites

@Jake Lo Instead of using bootx64.efi i use modGRUBShell.efi to do setup_var work. After I set 0xA10 to 0x2(64M). I finally got 4k outputs. But the solution givea me another nightmire. When I boot windows from opencore. It gives me a BSOD with a"acip_biso_erro stop code". ( Windows boots well if using windows boot manager and before the modificaion to 64M).

Also, it completely rendered trackpad gestures unsable. (I can't modify trackpad settings. It says trackpad not found). My wifi works randomly when i start macOS.

And somtimes It gives me a black screen before i login and shutdown itself automaticly. And I press the power button again. The screen come back again. It's really wired.

I didn't expect this simple command would does so much inconvinience. Any idears?

 

 

Link to post
Share on other sites

@Jake LoYes. several times. I've updated to opencore 0.69 and reset nvram again. It doesn't help. One out of ten times i can get into macOS successfully.  I get stuck once with "voodooI2ccontroller" related verbose  message. In the other eight times, I saw the apple logo for a blink of a eye and, I think, it went to sleep after a minute.(black screen withe this one minute) The light of the power button went off. After that, I pressed the power button and saw the login screen. I logged in. Sometimes wifi didn't work and all the time trackpad didn't work. I have no clues. I've include two screen shot. one for the stuck during boot up and one for verbose message right before it went to sleep(I guess). I came a long way to get 4k work and I don't want to give up. Please help me.

 

IMG_6624.jpg

IMG_6625.jpg

Link to post
Share on other sites
  • Solution

@Jake Lo I finallly get it work now. I followed opencore guide and clear up my acpi folder and delete dsdt.aml and ssdt-xosi.aml. The problem is due to dsdt conflics I think.

Now 4k, wifi and trackpad all woking perfectly. I'll upload the efi folder and bios offset file. If anyone one using latitude 5400 and want to use my efi, just take it. 

bios offset file is used to find bios option offset(latitude 5400). If anyone want to use 4k, just use modGRUBShell.efi to boot and use setup_var command to modify DMVT to 64M ( In my case it's setup_var 0xA10 0x2)

Thank you Jake Lo for helping me along way. Best regards!

EFI.zip setup IFR.txt.zip

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...