Jump to content

D820 Lion 10.7.4, Dockstation and DVI issue


Noodle
 Share

Recommended Posts

Hi Forum,

 

I just upgrade my D820 to 10.7.4 and using EDP 3 now. Had to say: great work.

 

Now I want to use my Dock station and connect to a Dell monitor though DVI. But Lion cannot find Dell monitor. If I connect though VGA, it can find. Ok, I can live with VGA. But when I close lip, it still show as two monitor instead one. Ok, I make it as mirror, so both should work. But after I set it to mirror, the display become some big color blocks with mouse cursor on it. As soon as I disconnect VGA cable, it back to normal. But if I connect VGA cable, it's big color blocks again. I cannot even disable mirror.

 

Anybody having this issue? How do you use Dock station?

 

BTW, this is Intel GMA950 graphic card.

 

Thanks

 

Noodle

Link to comment
Share on other sites

Thanks Bronxteck, that fix mirror mode issue.

 

I checked DSDT, and looks like EDP 3 installed DSDT that contains LCD only. Original DSDT for D820 contains TV, VGA, LCD, DVI. So I tried to add them back. But now no display on internal LCD. It recognize the internal LCD display, but just turn it off.

 

Any idea?

 

Noodle

Link to comment
Share on other sites

I have had success getting a D620/Intel to work in a DockingStation

with the VGA output,with 10.6.8. I have never tried Lion, or a D820.

 

Try the following.

 

1) Go back to your previous version of the DSDT.

Without the TV/VGA/DVI change.

2) Change "AAPL,Haslid" to "AAPL,HasLid" in DSDT.

Note the "Capital-L".

 

 

It worked for me.

Link to comment
Share on other sites

 Share

×
×
  • Create New...