Jump to content

[Solved] Latitude 5510: TrackPad not working


skavenger0816
 Share

Recommended Posts

Hi,

 

I have a Latitude 5510 laptop with an i7-10610U running Catalina 10.15.6 with OpenCore.

Thanks to @murkie for his EFI posted in this thread. I used this as template for my config.

 

Specs:

  • Intel i7-10610U processor
  • Intel UHD 620 graphics
  • 16GB 3200Mhz DDR4 Memory
  • 512GB NVMe Drive Hynix
  • Realtek ALC3204 Audio
  • Intel Wi-Fi AX201
  • Intel I219LM NIC

what is working:

Keyboard with backlight

full graphic acceleration

HDMI-out with full resolution

sound - Internal speakers

sound - HDMI

LAN

WLAN with USB-Dongle

USB is working, but not optimal

Battery status

 

what is NOT working:

Touchpad and Buttons

WLAN internal

Brightness on boot too low

Sleep/wake

USB-Ports nned to optimize

Bootmenu takes to much time to appear (OC -> misc ... Resolution: Max??)

 

 

Q:

- I've created a "Sysreport" via the OC quirk and have a lot of .aml-files. What to to with these? compiling or patching - i don't now what to do.

- what i need to get the touchpad to work?

 

Any help or information would be appreciated

 

If this post is on the wrong place, please move it.

 

EFI-skav210621-1.zip opencore-2021-06-20-211155.zip SysReport.zip

Edited by Hervé
Split to own thread
Link to comment
Share on other sites

Hi,

 

uhm, i don't really understand your question.

 

--> SSDT-Patched.aml comes from the Source-EFI from murkie - actually disabled
 

These files files in the "SysReport.zip" are created by OC automatically. I have not made anythink with these because i don't know what to do with them.

 

Sorry for my bad english...

After disabling and deleting all other Voodooxx-kexts except VodooPS2Controller and its plugins i get my touchpad and its buttons working.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...