Jump to content

E6440: USB flash drives don't work in Big Sur


Title
 Share

Recommended Posts

Hi all,

 

I recently updated my Dell Latitude E6440 (Intel Core i7-4600M, Intel HD Graphics 4600 + AMD ATI 8690M (not used)) from Catalina to Big Sur. When i connected flash drive, this message showed up:

akc usb needs power
Connect "Flash drive name" to USB port in this Mac

 

After installing USBInjectAll mouse receiver worked, but flash drives still didn't. Before updating to Big Sur, USB worked fine.

 

Old EFI: https://github.com/xiangagou/Dell-E6440-Hackintosh

New EFI: https://github.com/KD-AIP/Hackintosh-E6440/tree/BigSur_OC

config.plist with USBInjectAll: config.plist.zip

 

Any ideas how to fix this?

Link to comment
Share on other sites

  • Administrators

There would be so much to. say about your Catalina setup (especially the set of add-on kexts and the Clover config!) but, at least, you correctly used USBInjectAll kext + SSDT-UIAC table. These defined the USB ports of your E6440 laptops. You also used a patched DSDT in which specific power settings for your EH01 & EH02 USB2.0 controllers + XHC USB3.0 controller were also defined in dedicated _DSM methods:

                    "AAPL,current-available", 
                    0x0834, 
                    "AAPL,current-extra", 
                    0x0898, 
                    "AAPL,current-extra-in-sleep", 
                    0x0640, 
                    "AAPL,device-internal", 
                    0x02, 
                    "AAPL,max-port-current-in-sleep", 
                    0x0834

 

For Big Sur, you made a few additional mistakes: you did not use your previous patched DSDT -ok, why not?- and that would probably be Ok had you not made the choice of injecting SSDT-EC-USBX table (which is for Skylake & later systems) AND SSDT-EC table (which is for Broadwell and earlier systems). The trouble is that SSDT-EC-USBX injects the following power settings for USB ports:

                    "kUSBSleepPowerSupply", 
                    0x13EC, 
                    "kUSBSleepPortCurrentLimit", 
                    0x0834, 
                    "kUSBWakePowerSupply", 
                    0x13EC, 
                    "kUSBWakePortCurrentLimit", 
                    0x0834

which are totally different settings the what you injected before.

 

I would recommend you start by removing SSDT-EC-USBX table and all references to it in your OC config. I'd bet square prunes that your USB ports will work much better afterwards and that you'll no longer have power-related problems with your USB keys/storage devices.

 

In addition, given that you've generated your USBMap kext, I'm not sure you still need the SSDT-UIAC table. Check that out but to me, it's either USBInjectAll kext + SSDT-UIAC table or USBMap kext (as it were with Hackintool-generated USBPorts kext).

Link to comment
Share on other sites

Thanks for your help!

 

I didn't use USBPorts kext (I'm dumb), but now I did and it works perfectly!

 

I have also two questions:

I have now noticed that macOS and Hackintool don't detect HDMI. Is it problem with WhateverGreen or config.plist?

 

And audio jack does work but only when laptop is connected to dock. Is it problem with AppleALC?

Link to comment
Share on other sites

  • Administrators

It's good practice to keep threads on-topic...

 

This being said, what do you mean by "don't detect HDMI"? HDMI video & audio output require tuning/patching on Haswell systems.

Video output requires:

  • patching pipe of HDMI port/connector (usually con1) to change it from 0x09 to 0x12 (or system will freeze/hang on connecting/disconnecting the HDMI cable)
  • patching HDMI port/connector (usually con1) to change connector-type to HDMI (00080000) is recommended though usually only necessary for HDMI audio

Audio output requires:

  • patching HDMI port/connector (usually con1) to change connector-type to HDMI (00080000)
  • injecting hda-gfx property to iGPU device
  • renaming B0D3 device to HDAU

You'll find sample configs in our HD4600 graphics R&D topic as well as in most if not all our guides for Haswell laptops or threads pertaining to HDMI output on Haswell laptops.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...