Jump to content

D430 Lion lost wifi with update to 10.7.3


moonman
 Share

Recommended Posts

Just can't seem to get wifi back. It was working after initial install of 10.7 but after update to 10.7.3 I can't get wifi back. I've tried everything. I have a DW1395 which has always worked perfectly in Snow Leopard with the Broadcom43XXFamily.kext (version 3.1) that I added afterwards.

 

I have a dual boot Snow Leopard 10.6.8 and Lion 10.7.3 system.

 

Wifi works perfectly under 10.6.8. In my Extra folder I have the Broadcom kext and IONetworkingFamily.kext (v. 1.10), but no IO8211Family.kext.

 

In my Lion Extra folder, I tried adding the Broadcom kext but that didn't give me wifi.

I have IONetworkingFamily.kext (tried v. 3.1 and 2.0) and I have IO8211Family.kext (v. 3.1) but no wifi.

 

Any ideas? Thanks.

 

 

SUCCESS!

 

I installed the kexts from my Snow Leopard partition that gave me working wifi under 10.6.8. Used Kext Wizard to install them then ran Repair permissions, rebooted and had wifi under Lion 10.7.3!

 

The 2 kexts are: Broadcom43XXFamily.kext (v. 3.1) and IONetworkingFamily.kext (v. 1.10).

 

Hope this helps others. Cheers.

Link to comment
Share on other sites

 Share

×
×
  • Create New...