Jump to content

Mountain lion - Windows 7 dual boot


Recommended Posts

I am trying to get mountain lion and windows 7 to run off the same drive, but I don't seem to be having any luck. I had previously had lion and win7 on the same disk without any issues, but for some reason chameleon doesn't seem to start properly. This what I did:


Wipe drives - create 2 partitions

install OSX on partion 1 (including EDP and such)

restart - works great, get the chameleon boot loader

Restore image of win7 on other partition

restart - chameleon opens.

Try win7 - no go, disk needs repair. repair using win7 install disk

restart - boot0 then into windows...no chameleon.


any one have any ideas?


it seems the MBR from windows somehow messes with the chameleon.


if I boot from the USB install disk I get chameleon, and then I can start OSX no problems.

Link to comment
Share on other sites

how is your windows 7 backup and restored? Did you have the hidden partition installed by Windows 7?


When you install Windows 7/8, always partition the harddisk into a large enough partition first. Do not allow windows installer to create the partition from a new harddisk. It always creates a hidden 100M partition in front of the C-drive. This is like EFI boot partition containing boot files but creates a lot of problem in backing/restoring and migrating to other disk.


My preferred windows backup tool is Acronis True Image in a USB stick

Link to comment
Share on other sites

I used acronis as well, when I restored the image I only restored the C drive - so I unselected the system reserve and the MBR.


what's really wierd is if I resotre my image of Lion, then Chameleon will work again. I'm wondering if there is an issue with the Chameleon version??

Link to comment
Share on other sites

It turns out the fix is actually right on the first page of the site!!





I now seem to have everything up and running! Install was relatively easy, only other real problem was when making the USB install disk. The first USB key I used, the boot kept getting stuck at the PCI. I switched USB keys, and the second one worked great! it seems a bit strange but it worked ok!


time to restore from time machine and see if everything is working!

Link to comment
Share on other sites

  • Create New...