Jump to content

E5470: Bluetooth isn't detected


Recommended Posts



It's my first experience with this laptop. I'm using the default Intel combo card with Jake Lo's E7x70 pack. WiFi works well, but Bluetooth is not detected at all, despite all the right kexts in place.

I mapped USB ports using USBMap. The number of ports is limited now, everything works including the webcam. Yet there is no sign of Bluetooth. It didn't show up in USBMap at any point.

I'm using Big Sur and the latest BIOS if it makes a difference. Does someone have any ideas?

The list of the kexts and config.plist are down below.


AirportBrcmFixup.kext		SMCBatteryManager.kext
AirportItlwm.kext		SMCDellSensors.kext
AppleALC.kext			SMCLightSensor.kext
BrcmBluetoothInjector.kext	SMCProcessor.kext
BrcmFirmwareData.kext		SMCSuperIO.kext
BrcmPatchRAM3.kext		Sinetek-rtsx.kext
BrightnessKeys.kext		USBMap.kext
IntelBluetoothFirmware.kext	VerbStub.kext
IntelBluetoothInjector.kext	VirtualSMC.kext
IntelMausi.kext			VoodooPS2Controller.kext
Lilu.kext			WhateverGreen.kext



Link to comment
Share on other sites

Yes, I've done all that, following the guide. With USBInjectAll and xhciportlimit=true, Bluetooth doesn't show up anywhere, including the USB section in the System Report. Just checked with Hackintool to be sure, no luck.

Initially I used a different pack with an older OC, and at first Bluetooth worked (or at least it was detected). Then after one of the countless iterations it just disappeared. Interestingly enough, when I return to that exact pack, Bluetooth still doesn't work. And of course it's enabled in BIOS, I checked.

It feels like some kind of magic is involved. I used to experience something similar on E6430, specifically with Bluetooth.

Link to comment
Share on other sites

I'm not sure how this works, but I solved it by loading Ubuntu. Bluetooth was available in it, and after rebooting to macOS it showed up in USBMap under HS08. I think it might be some soft airplane mode that was turned on but couldn't be turned off in macOS itself. And then Ubuntu reset it. I don't know, just a theory.

Unfortunately I discovered another unrelated issue. When the laptop is charging, the trackpad is practically unusable. Oh well...

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...