Jump to content

Latitude E5570: Need help to fine-tune Catalina


xuanhung1509
 Share

Recommended Posts

Hi guys.
After a while messing around, I’ve got Catalina 10.15.7 installed on my notebook. Most of the things work, though there’re still some I need to fix, clean or optimize.


1. Adjusting brightness:
I read Hervé’s post for patching DSDT to adjust brightness, but I don’t know where to put the patched DSDT into (Dortania says that I should not put DSDT.aml into ACPI). After a few researches, I got Fn + F11/F12 working for adjusting brightness. It worked after I insert a kext (BrightnessKeys) and a SSDT (SSDT-5378) into OC Folder. What is strange is that two elements came from different devices. The kext is from here, and the SSDT is from here. Without one of these two, it doesn’t work. Can I got a more optimized solution for this?


2. Sleep:
Sleep seems to work if I click Apple Icon -> Sleep. However, if pressing Fn + Insert or closing the lid or pressing power button, sleep does not work properly. In particular, when pressing Fn + Insert, the screen goes black, but the led indicator stays static, and when I hit power up, the screen turns on immediately. On the other hand, closing the lid or pressing power button does not work at all.


3. Screen goes black after disconnecting with HDMI:
When this happens, my system seems to become unresponsive. This morning, I tried to sleep (choose Sleep under Apple menu) before disconnecting. This time, the screen turned on, but somethings turned out to be broken: Bluetooth became unusable, and adjusting brightness using Fn + F11/F12 didn’t work anymore. After restarting, adjusting brightness worked, but bluetooth stayed the same (I guess the Bluetooth kexts broke)

2145529650_ScreenShot2021-12-08at7_53_10AM.png.0365ce5131d2c77958ef70bb4ec2f4ab.png


4. Touchpad:
Using standard VoodooPS2Controller kext works for me, but I see that there’s a kext that is made exclusively for ALPS on the forum (by Bronxteck) and I want to try that. However, after I installed that kext, touchpad does not work, it even does not recognize my touchpad as ALPS, and I've got to revert back to the standart kext. Could you suggest a workaround?


5. USB ports:
These are all USB ports on my laptop, less than the limit (15). Should I need to disable XHCIPortLimit in config.plist?

1293727196_ScreenShot2021-12-08at1_23_23PM.thumb.png.c7974a8d0da61ff43f4ac1bcd6a9096c.png

 

In addition to these, are there anythings else I need to optimize and clean up?

 

My laptop specs:
- Model: Dell Latitude E5570
- CPU: i7 6820HQ
- GPU: HD 530 + AMD R7 370 (disable using SSDT-dGPU-off)
- NICs: Intel Wireless AC 8260 + Ethernet I219-LM

- Audio: Realtek ALC293 + Intel HDMI Audio

- Hard Disk: Lite-On SSD M2 256GB

 

This is my OC folder: E5570-OC.zip

 

I hope you guys will take a look at it. Any help is appreciated. Thanks!

 

Update: after proper USBMap, sleep and HDMI works well.

Link to comment
Share on other sites

https://drive.google.com/drive/folders/1Oy0bu3vNO-UG6FP-tK0HpH0RYf20zhiF?usp=sharing test this EFI in USB if start ioreg .

 

In this USB port mapping I notice that the connectors are not mapped and SS04 USB 3.0 port does not have the corresponding HS04 which should be the USB 2.0 part, I have also modified this in my EFI, take new photo of the USB as above

1851237689_Schermata2021-12-08alle09_25_31.png.5f8373421106d7c9f13ae43fcd463b09.png

 

In the SSDT I fixed all the devices, you don't need anything else, your Dell should work quite well.

1508610306_Schermata2021-12-08alle09_32_58.thumb.png.ba66002612abdd9da92dcc7b819531ab.png

Link to comment
Share on other sites

After replace my EFI with yours, I got stuck at this screen. Also, it was little strange when booting up. Normally I would see the OEM logo one time (before selecting boot drive), but this time I see one other. I'm not sure if it has sth to do with the stuck.

IMG_20211208_154604.thumb.jpg.7f905fd3d13f558d1c9b537e790edeac.jpg

Oh and about USBMap, I may need to double check it (after my laptop boot up), cuz I remember assign some ports to internal already.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...