Jump to content

DW1820A Wifi Issues


Dark Shinobi
 Share

Recommended Posts

Setup: HP Probook 450 G4
CPU: Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz   2.71 GHz
Ram: 16GB
Having trouble with my DW1820A card on the latest update of Monterey 12.2. Up until Catalina I've been using Clover bootloader, and decided to swap to Opencore for Big Sur. Everything was moderately decent on Big Sur, however, when I updated to Monterey 12.2, my card constantly kernel paniced the system. Only way I was able to boot was to disable the card in the Bios. I've tried all resources I could find to solve this issue.. the 1st Workaround found here with the Catalina's IO80211Family kext. No success, Tried the second work around also no sucess. Then I found a post where @Hervé mentioned that it might be an Opencore issue, so I reverted to Clover and copied everything in the outlined post.. still no dice. I've attached my Clover folder, and am open to suggestions. 

 

 

CLOVER.zip

Link to comment
Share on other sites

  • Administrators

Works for me on my Latitude E7270 in Monterey with just the properties injection stated in point #3 of the last post in the BCM4350 thread. No add-on kext or injector whatsoever. Basically, all that I really need in Clover is:

compatible        pci14e4,43a0        STRING
pci-aspm-default  0                   NUMBER

the rest being purely cosmetic.

 

Try without ACPI AirportFix. In fact, one must wonder if you really need all those ACPI patches and renamings in your Clover config. Boot args are questionable also (especially the useless & duplicated Yosemite-only kext-dev-mode=1).

Post an IOReg extract.

Link to comment
Share on other sites

 Share

×
×
  • Create New...