Jump to content

Latitude 7390: external HDD shown as internal


Treudel
 Share

Recommended Posts

Hello,

I run Monterey with OC 0.78 in a Latitude 7390 (no touch-version) and I'm 99,5% satisfied.

My specs:

i5 CPU

16GB RAM 

1TB SSD

DW 1560

 

Everything works perfect. Touchpad with two-finger zoom and rotate, 3-finger swipe and so on. HDMI as well as side car.

Boot-time is about 60 seconds which is ok for me. Sleep/wake perfect, audio, camera anything else absolutely fine.

 

The only thing is that external HDD's/SSD's are only displayed as internal drives which is of minor interest but it would be nice if this also would work correctly. I tried a different EFI where there are quite a few issues missing but this one was as it is on a "normal Mac".

Does anyone has a clue how to solve the external display icon topic?

I tried to map my USB ports with hackintosh - unluckily no success here.

 

Looking forward to your suggestions. EFI might be uploaded if needed.

Link to comment
Share on other sites

  • Moderators

Issue with your USB kexts. According to the IOReg file, you have HS02 connector type as 0xff = internal

It's clear that you have an external usb drive plug in there

Change the port to 0x3 = USB 3.0

 

Link to comment
Share on other sites

I tried the links you posted but didn't succeed in the end (Win11 used). I didn't know exactly whether one or two kexts have to be injected.

In the end I succeeded with Hackintool and a guide posted on YouTube.

In the end I tested two USB3 sticks on my ports (HS02 didn't have to be changed), changed the connector to USB3 and changed the USBPorts.kext without screenshooting my config.plist and now the external drives are shown as external. Anything else works as before.

 

Everything fine, you made my day. Thanks a lot!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...