Jump to content

OSX: Howto disable spaces animation


Leon
 Share

Recommended Posts

  • Administrators

Ever wondered if you could get rid of the spaces animation ? - from 10.6.x you can..

 

To disable the animation, do the following:

Open /Applications/Utilities/Terminal.app.

Copy and paste the following into the terminal window and then press enter:

 

defaults write com.apple.dock workspaces-swoosh-animation-off -bool YES && killall Dock

 

If you'd like to re-enable the animation, just do the following:

 

Open Terminal and copy and paste the following into the terminal window and then press enter:

 

defaults delete com.apple.dock workspaces-swoosh-animation-off && killall Dock

 

Edit:

Unfortunately, this only disables the "move directly to a space" animation that that is triggered by jumping to a space with a modifier-arrow key or modifier-number key or switching to a program in a different space. It does not disable the zoom-out/zoom-in animation for moving from spaces overview to a specific space. I use that method of transition fairly often, so it would be very nice if there was a switch for that one as well (or at least a way to speed up the animation).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...