Jump to content

Latitude 5591: 2 Minute Blackscreen between FileVault and Desktop


Recommended Posts

Hey Everyone,
I've successfully managed to install Monterey 12.4 on my Latitude 5591 apart from a few issues. I intend to release a guide/GitHub documentation on the install process after these last flaws are solved.

- Blackscreen during boot/Slow Boot(?)
Currently, I get a black screen for around 2-3 Minutes during Boot. After I enter the filevault password I get the loading bar which fills approximately for 1/3, but after that i get a 2-3 Minute long Blackscreen until the Laptop ends up on the desktop. If I was to boot with "-v" the logs would approximately run as long as the 1/3 bar, but then get followed by a blackscreen -> Desktop scenario as well.

- I have yet to look into CPUFriend for power consumption (is that even required on that platform?)

- Replace the Intel drivers with required BRCM fixes once the DW1820 arrives


CPU: i5 8400H

GPU: Intel UHD 630, no Dedicated

RAM: 2x8GB

SSD: Kingston NV1 (with working TRIM)

Touchpad: ALPS, with full Mutitouch and gesture support as well as working trackpoint in the middle

Brightness Buttons: Fixed using SSDT-BRT6 against GPU0


My current EFI directory is attached, I'd appreciate some hints in regards to the blackscreen/slow boot as I am pretty clueless about that currently.

Note: The zip misses the "AirportItlwm.kext", which is however present on my system. It has been removed from the zip so that it can be uploaded here.

Thanks in advance :)


Link to comment
Share on other sites


Using OpenCore 0.8.


The blackscreeen issue is post-Filevault. The slow boot I had before Filevault (so between Opencore and FV) had been solved by adjusting the touchpad polling.

From Power button press till FV Password the system takes ~20 seconds to boot, but from Filevault to Desktop its ~2-3mins as theres a black screen period of around 2 mins between the "loading bar" boot animation and showing the desktop.


I can provide a Video of what I mean once I get home.


P.S. does anybody happen to know a good resource to still get a BRCM WiFi card? Dell sent me an QCOM DW1820 instead of a DW1820*A* and refuses to sell me any of the 1560, 1820A or 1830 claiming they "Do not support Linux or Opensource"...


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...