Jump to content

E6220 (i7-2640m, 8GB): Mojave fresh USB installation stuck


Recommended Posts

Trying to install Mojave to an E6220 (A14 BIOS, i7-2640m, 8GB, 500GB regular drive). Followed the Herve Guide. Created the USB installation stick (Mojave 10.14.6, 18G103, from Apple site), Clover/EFI (all directly from the guide's download link). Booted from the USB, toggled the "-verbose", launched the install. But the install process stuck at the following stage (see capture screen - Stalled-1.jpg):


Waited for 20+ minutes. No progress. So, reboot the machine and tried again. It stuck at the exactly the same point.


There were number of "ACPI" errors at the begining, before reaching to this point (see attached screen capture - Stalled-2.jpg).


Haven't figured out how to capture the entire screen output to a debug log file yet. I will try to do that if it helps to identify the root cause.


What could be the issue? Your help will be greatly appreciated!


Additional detailed for this machine:

E6220, A14 BIOS, i7-2640m CPU, 8GB RAM, 500GB drive.

Wireless cards (Intel Ultimate-N 6300, and Broadband GPS 3G card).




Link to comment
Share on other sites

No, I haven't changed the CPU ssd. I was hoping it would at least boot, without KP.  Based on your High Sierra Guide, that appears not to be the case. 


BIOS settings followed exactly your guide.

I will try your provided CPU PM file (just noticed that!).

Link to comment
Share on other sites

Reporting back:  Tried your CPU PM file, SSDT-PM_i7-2640M.aml file, by renaming to SSDT-PM.aml and replaced the original SSDT-PM.aml in ACPI/patched folder. This time, it went a bit further (a couple of more message lines), then stuck.


Noticed this CPU PM was for i7-3540m, isn't exact match for i7-2640m (3/3.7GHz vs 2.8/3.5 GHz, also Ivy-Bridge vs Sand-Bridge).


I will looking into the NullCPUPowerManagement kext, as you suggested in High Sierra guide, to boot ups the system first.


One question: I see no DSDT.aml in Majove Guide. Is this the intended SSDT only patch solution?


Really appreciated your help!






Link to comment
Share on other sites

  • Administrators

The SSDT I provided above IS for your i7-2640M! You must have confused the host processor (i.e. the i7-3540M of my E6230 on which I generated the table) and the target processor... Read the contents of the file with all due care.


Re: DSDT, correct, there's no patched DSDT in the Mojave and Catalina packs I provided. Simply because I found I no longer needed it.

Link to comment
Share on other sites

Thank you very much for your reply.


My apology for confusing the CPU PM file. I opened the file, with MaciASL, and saw "Intel(R) Core(TM) i7-3540M CPU @ 3.00GHz" as listed as "host processor" in the DeBug statements, and did not realize that was just a reflection of the host (i.e. E6320) where the ssdtPRGen was run. Thank you for correcting my mistake.


I tried the install again on another E6220 unit (i5-2540m CPU, everything else identical), using the original EFI folder from the guide, and ended stuck at the exactly the same point. So, it appeared to point to a likely similar root cause. In this case, also a mismatched CPU (i5-2640m vs 2620m PM file). 


I will try two things next: 1) High Sierra Install Guide.  2) NullCPUPowerManagement.


Thank you!

Link to comment
Share on other sites

  • Administrators

Just as a test, when Clover main menu appears, go to the Options menu and add boot-arg -igfxvesa in case it's the graphics causing issue. But I don't remember needing that myself.


NullCPUPowerManagement is not going to be of any use here; it's not an issue related to CPU PM.

Link to comment
Share on other sites

Reporting back for the update with Majove install: 

  • Tried the "boot-arg -igfxveda" option, no difference.
  • Also tried NullCPUPowerManagement, also no difference. However, I wasn't sure if the kext was actually loaded during install.

So, I switched to the High Sierra Guide, on my E6220 unit (i5-2540m CPU). 


My 1st attempt, using the original EFI from the guide, I encountered kernel panic. My guess this was due to mismatched CPU PM. Wanted to try NullCPUPowerManagement, but wasn't sure how to do the following - "The kext just needs to be added to /Library/Extensions followed by permissions repair/cache rebuild", for an USB install.


So, in the end, I ended in DosDude1's Catalina patcher, mentioned in your Catalina Guide, and an EFI folder (Clover setup) from another googled link. I was able to get a working Catalina on this E6220. 


I still want to try your guide here with all the impressive enabled features. So I created CPU PM for i5-2540m CPU using the working Catalina setup, and then dropped it in the High Sierra EFI folder. Started the High Sierra install, this time it went smoothly and succeeded! So, all it needs is the correct CPU PM file, just as your guide suggested. 


I also tried this new CPU PM file on the Majove install, still stuck at the same point. So the issue is not CPU PM related.


Anyway, I am attaching the CPU PM file here for i5-2540m, in case someone else need it.


Update: Using your provided CPU PM for i7-2640m CPU (#2 post above), I was successful with High Sierra install. on my 2nd E6220. 


Will report back more later.




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...