Jump to content

Dell Latitude 5290 2-in-1: Trackpad, Touchscreen and Combo Jack Mic issues.


Recommended Posts

Trying to do the finishing touches on an otherwise working build for my Dell 5290


Audio - ALC255 using Alcid=30

ALPS Trackpad detected as internal USB


- ALPS Trackpad (HS02) does not work when VoodooI2CHID.kext is enabled. However, Touchscreen works as intended with Apple gestures. ([email protected],1)


- Trackpad works when VoodooI2CHID.kext is disabled. However, Touchscreen does not work. Also, Cannot get Apple trackpad gestures to work.


Can't get them both working together


- Sound works (Speaker OUT, internal Mic IN) however, external LINE IN Mic does not work. Have tried using ALCPlugfix without success other than that it helped detect my headphones faster when inserted and ejected from audio combo jack. Was very delayed before. 


I've tried as much as I can to figure this out but would like some assistance wherever possible. Please help or link me to proper guides that I may not have come across. Thanks


CleanShot 2022-09-03 at 19.16.45.png

CleanShot 2022-09-03 at 20.09.32.png

CleanShot 2022-09-03 at 19.33.29.png

MacBook Pro IOREG.ioreg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...