Jump to content

A bit of help with a D630 and 10.7.4?


plastikcaktus
 Share

Recommended Posts

Hello Folks,

I've been trying for the past 2 days to get my D630 running 10.7.4, and for the life of me, I cannot.

I used a MBP running SL to get my original pen drive running using MyHack and the EDP with a DMG of Lion and proper bootpack, and it *seemed* to work and install, but after install I would get those bloody boot0 errors. Could not even get the terminal to run diskutil, could not run binaries. I figured the installer was borked.

 

The MBP was not mine, so I don't have access to it anymore. Just my Win 7 system with a Lion VM (vmware).

 

So I decided to load up my Lion VM, and try another flash drive and install. I used the MyHack, and then loaded the Extra Bootpack for my D630 - Intel - 1280x800, and now...well...shoot. It gets to the apple screen with the twirly loader, and then kernel panics. I ran -v to get the information, and it *seems* to be an issue with the X3100 drivers?

 

I've been at this for two days...and...i'm about to pull my hair out. I know so very little about Mac OSX (well, I can use it, just don't know how to do all the cool driver stuff ya'll do), but I'm trying. Any help would be appreciated.

 

D630 ATG A17 Bios

C2D @ 2.6Ghz

4GB DDR2

Intel Crestline Graphics Bios 1588, 8MB (how weak is that) - 1280x800

Broadcom Wifi

40GB HD (AHCI mode enabled in bios).

 

Here is a picture of the error in question...

 

IMG_20121114_203128.jpg

Link to comment
Share on other sites

When creating the myHack 10.7 installer, did you mount the InstallESD image/package found inside the Lion image or did you just mount to the main Lion image? You need to do the former, not the latter.

 

The image I have is the install ESD image; inside is the Install Mac OSX Lion/library/packages/private/system. That's the one I've been using.

Link to comment
Share on other sites

  • Administrators

I'm beginning to wonder if the issue is not with the 10.7.4 version... It looks like the KP is due to ACPI rather than graphics and we all know the initial issues of updating Lion to 10.7.4: we had to revert to a previous ACPI kext (or was it IOPCIFamily?) to avoid dead machine...

 

If you can, try an install an earlier version like 10.7.2 or 10.7.3, from which you would then update to 10.7.5 with EDP support.

Link to comment
Share on other sites

  • Administrators

Great you got there and it seems you confirmed my suspicions.

 

Just install/run EDP and then it's a straight update to 10.7.5 (combo update or direct software update). See the related post in Lion section of the forum.

Link to comment
Share on other sites

 Share

×
×
  • Create New...