Jump to content

Dell Inspiron 1520: graphics acceleration problems under Tiger 10.4


Recommended Posts

I am testing 10.4.11 Tiger on a Dell Inspiron 1520.


Is there any way to get Geforce 8600M GT graphics acceleration to work with 10.4.11 Tiger?
I am using a MBP3,1 recovery disk, so the necessary kext such as nvda50hal is installed.


Dell Inspiron 1520, Core 2 Duo T9300, Geforce 8600M GT 256MB, 4GB RAM
STAC 9205: alcid=11
I am using Clover 5100.

DSDT and Clover's Nvidia inject work fine with 10.5 Leopard or later.


Also, AppleALC does not work.
Tested with both codecs created by goldfish and my modified AppleALC.

It is recognized in the system profile but not in the sound settings.


I am struggling because the information about Tiger is very out of date.

It works fine on 10.5 Leopard and later.


Additionally, Mac OS does not work shutdown.
The _PTS SLPE method does not work on the Inspiron 1520.
This has not been resolved in over 10 years.


Installed Tiger via VMware Fusion from recovery disk for MacBookPro3,1.
Tested by restoring the image to HDD.


My modified AppleALC
Tested with Work on 10.5.8 Leopard, 10.6.8 Snow Leopard -32bit and 64bit, 10.13.6 High Sierra.


In the future I plan to make it an archiving machine with Windows 7 to 11 and Mac OS 10.4 to 10.13 installed on a 2TB SSD.











AppleALC.kext_mod.zip DSDT.zip

Link to comment
Share on other sites

  • Administrators

Hmm. Afaik, Tiger lacks the required drivers for nVidia Tesla G8x/G9x. Support was introduced in Leopard 10.5 in which you'll find the necessary NV50 & associated GeForce kexts/drivers. So, no support for the GeForce 8600M of that Inspiron 1520 in 10.4.11.



But I'm probably in the wrong given that, according to what I read, MBP3,1 with GeForce 8600M did indeed ship with Tiger 10.4.9.


nVidia drivers in Tiger 10.4.11 (as seen in Pacifist with 10.4.11 combo update (Intel) dmg):

Tiger_GeForce_drivers.jpg   Tiger_NV_drivers.jpg


nVidia drivers in Leopard 10.5.8  (as seen in Pacifist with 10.5.8 combo update dmg):

Leopard_GeForce_drivers.jpg   Leopard_NV_drivers.jpg


If you lookup in SysProfiler/SysInfo->Software->Extensions of Leopard 10.5.8 (or later), you'll see the nVidia drivers that get loaded. You can then compare with what loads in Tiger.


Given the years that have passed since Tiger, you're very unlikely to obtain support for this ancien release and, at OSXL, we only ever supported systems running Snow Leopard or later. This being said, you may find this MBP3,1 IOReg extract useful in troubleshooting your machine; but it was taken in Leopard 10.5.8, not Tiger...


  • Like 1
Link to comment
Share on other sites

Thank you Hervé


8600M GT kext for Tiger is included in the following update.


MacBook Pro Software Update 1.1
This update requires Mac OS X 10.4.9 or later.




MacBook Pro Software Update 1.2
Mac OS X 10.4.9 or 10.4.10




However, it does not work as it is.
Adding 0x040710de to pcimatch in info.plist does not boot.

I need to do some more research.



Link to comment
Share on other sites

  • Administrators

Ok, I understand better now... 'was not aware of those very specific MacBookPro updates.

I don't believe trying to add the PCI id 10de:0407 to whatever kext is required at all. Your GeForce 8600M GT carries the same id as the nVidia GPU of the MacBookPro3,1. If you look into the Info.plist file of the NV50Hal kext, you should notice the presence of support for 0x040010de with mask 0xfff0ffff. That covers your GPU.


I guess you probably need to inject the nVidia properties of your nVidia card into Tiger, either through your bootloader or through a DSDT patch or through an injector kext (like NVInject) if you still manage to find one after all those years. Those would basically inject those necessary properties like NVDA,Parent, ports description, etc. You'll find plenty of examples on Hackintosh forums or here in the Dortania documentation.

  • Like 1
Link to comment
Share on other sites

I have tried everything, DSDT, device property, nvinject, etc., but nvdanvresman panics and won't start.
Unfortunately I would like to give up about Tiger.


I'll give it a few more tries.
If anyone has any ideas, please let me know.


It worked with the old AppleHDA 1.2.9 and AppleALC.
AppleHDA 1.3.6 included with 10.4.11 did not work.
Also, graphics acceleration does not work.
Perhaps a binary patch to the relevant kext is needed.




I have tried to make sure it works on all operating systems from Tiger to Sonoma.


10.7.5 Lion

Replaced with AppleACPIPlatform.kext ver1.3.6 from Snow Leopard 10.6.8.



10.8.5 Mountain Lion

Replaced with AppleACPIPlatform.kext ver1.3.6 from Snow Leopard 10.6.8.
Replaced with AppleSDXC.kext from Lion 10.7.5.



10.9.5 Mavericks



10.10.5 Yosemite



10.11.6 El Capitan



10.12.6 Sierra



10.14.6 Mojave

Installer created with Mojave Patcher.
Patch applied is graphics only.


OTA fix





10.15.7 Catalina

Installer created with Catalina Patcher without auto patch option.
Patch applied is graphics only.


DisplayPrefpane fix



OTA fix





11.7.10 Big Sur

kexts,kernel patch from OpenCore Legacy Patcher: MacBookPro5,1 configuration and root patch.



12.7.4 Monterey

kexts,kernel patch from OpenCore Legacy Patcher: MacBookPro5,1 configuration and root patch.




13.6.6 Ventura

kexts,kernel patch from OpenCore Legacy Patcher: MacBookPro5,1 configuration and root patch.



14.4.1 Sonoma

kexts,kernel patch from OpenCore Legacy Patcher: MacBookPro5,1 configuration and root patch.





Link to comment
Share on other sites

  • Create New...