Jump to content

Dell Inspiron 6000 (Snow Leopard only)


Recommended Posts

  • Administrators

Well, I've been adamant I'd get SL on that old thing.
The specs:

  • Intel Dothan Pentium M 745 1.8GHz FSB400 CPU (overclocked to 2.4GHz/FSB533 through FSB pin mod + VID4 volt mod)
  • 2GB DDR2-533 RAM (the max. supported)
  • Intel 915GM chipset
  • Intel GMA900 graphics controller
  • 15.4" WXGA (1280x800) LCD
  • Intel ICH6-M SATA controller with P-ATA/IDE HDD
  • 5400rpm 160GB IDE HDD
  • Ricoh R5C822 SD Card Reader
  • Broadcom BCM440x 10/100Base-T FastEthernet
  • Dell DW1470 (broadcom-based) mini-PCI wireless
  • Dell 350 Bluetooth adapter
  • Sigmatel STAC9751 AC'97 audio

This old laptop has been running Leopard 10.5.8 without a hiccup other than the occasional tiny graphics artifact since 2010: wifi, SD card, full QE/CI, screen extension tested up to 1920x1280 on my 40" TV, sound, etc.; all work.

Different story with SL. I've always had trouble accessing the HDD when trying to install SL, whether with Nawcom's ModCD or with myHack. It's seen, but can't be accessed properly. 'tried various IOATAFamily kexts or AppleIntelPIIXATA kexts, no luck so far. I always have to format the disk on another Hack and installation freezes immediately when HDD is to be written (at scrolling blue/white bar).

So I recently thought to try and do an installation off a D6x0 and simply port the HDD to the Inspiron. I first installed off my D630 nVidia (basic myHack installation, no EDP follow-up) and was able to boot SL 10.6.3 onto the Inspiron with the help of my own-made/partially patched DSDT table and legacy kernel 10.3.0. I was only getting basic graphics, but the rest appeared to work Ok. I was able to update to 10.6.7 and replace legacy kernel by 10.7.0 version. The laptop worked exactly the same afterwards, except for USB ports which were non-responsive. USB kexts had to be replaced by 10.6.3 versions to recover. I gradually started to add kexts to get Wireless, SpeedStep, Keyboard, etc. working. I got as far as I could, but could never get full graphics support like under Leopard.

Dinesh prepared a new, much more tuned-up DSDT table which I started to use. Regarding graphics, I noticed that the GMA950 kext (as used in Leopard) were not loading, presumably due to blacklisting during installation on the D630 nVidia. No matter what I tried, it would no work.

So I tried the same, but with an installation pre-made on a D620 GMA950. The difference this time is that it would not boot to completion and I would only get an empty gray screen at the very end, right when the desktop should appear.

I then tried to replace all GMA + IntegratedBuffer kexts by those from my 10.5.8 installation. On reboot, I got to desktop with 1280x800 resolution, but no GMA950 or IntegratedFramebuffer kext appeared loaded. Ok, I had not done re-run myFix after replacing the kexts.

Following re-run of myFix, right at the point where I should get the SL desktop screen, all I get is a blue background screen for a few seconds and the laptop does a reset. However, if I boot in safe mode, I get to the SL desktop Ok and the IntegratedFramebuffer kext is loaded. I don't appear to have full QE/CI (menu bar is not translucent) but I'm provided with a choice of screen resolution. It'll run stable for hours in that mode.

It looks like I'm getting there, but I admit being lost as to why the laptop resets on completion of regular boot.

If anyone has any ideas...

Link to comment
Share on other sites

  • Administrators

Well, I managed to make good progress thanks to the advice and support of Dinesh + Mario. Thanks guys.

The biggest challenge was getting the Video/Graphics to work properly and with acceleration. That was kind of achieved by pretending GMA900 to be GMA950 but quite buggy (most notably the top menu bar) ... dry.gif

Added Voodoo Battery + SpeedStep emulator + Wireless + Bluetooth + Audio as well. All Ok and sleep even works natively (no SleepEnabler, BT + Wireless resume on wake + wake on USB supported)! :rolleyes: SD card reader to be tried.

It shuts down Ok, but does not restart... huh.gif

I now need to finalise settings to EDP standards and attempt updates to 10.6.7 and 10.6.8. Updating to 10.6.7 should nearly be a straight thing but I already know that I'll have to revert to 10.6.3 USB kexts to get the ports back. I'll probably wait for the EDP validation (if any) before attempting 10.6.8.

Link to comment
Share on other sites

  • Administrators

Update & conclusion...



  • SL 10.6.8 (replacing USB kexts by those of 10.6.3)
  • battery info
  • speedstep
  • audio
  • wireless
  • bluetooth
  • sleep & wake
  • shutdown
  • graphics resolution and switching (i.e. full framebuffer support)


Not working:

  • graphics HW acceleration (QE/CI not exactly obtained, too buggy for honest decent use)
  • restart


SL Installation is the major issue as I never found a way to sort out the lack of proper HDD recognition/access when installation starts. The trick was to install SL on the HDD connected via USB to a D620 GMA950, do a basic/generic installation of SL 10.6.3, perform combo update to 10.6.8 and add legacy kernel 10.8.0 v2. Then the HDD could be put back in the Inspiron 6000, SL 10.6.8 booted and tuned. Rather unpractical and unsuitable for any standard user.



Link to comment
Share on other sites

  • Create New...