Jump to content

D630 Lion 10.7.5 Hibernate/Safe Sleep


Hackinbosch
 Share

Recommended Posts

Hi All,

 

I'd like to run 64bit OSX all the time - as I have 8GB memory in my D630 (Running Lion 10.7.5) - but when running OSX 64bit the laptop won't go to Hibernate/Safe Sleep when I close the lid.

 

When running 32bit OSX and you close the lid, the machine closes down so that only the power LED flashes slowly (is that Hibernate/Safe Sleep?), and when I open the lid the machine wakes up and after inputting password I'm back where I was before I closed the lid. This is what I want when running OSX 64bit, but instead the machine just stays running. Open the lid and the desktop is as it was before it was closed.

 

Can anyone help?

 

I use the D630 for Ableton live and generative audio testing using cycling 74s Max 6, and OSX 64bit reduces the cpu load in Ableton and Max drastically. If I could leave the system running all the time in OSX 64bitand only close the lid when I'm not using it that'd be ace.

 

Thanks

Tim

 

 

Link to comment
Share on other sites

  • Administrators

Am I right to assume that you have a D630 with nVidia GPU (X3100 not being supported in 64bit mode)? Which BIOS version are your using and are your settings matching those published in the pinned thread?

 

Could you open up a Terminal window and type 'pmset -g' and check the hibernate mode value (ideally, should be 0).

 

You'll see that I'm running ML on my D630 nVidia, not Lion, so that's 64bit only and I have no problems with Sleep/Wake. I'll try to set it up with Lion on an external HDD to check, but I expect everything to work in 64bit kernel mode under Lion too.

 

Was your D630 Lion installation done with our recommended myHack + EDP method?

Link to comment
Share on other sites

Hi Herve,

 

Sorry for the (very) late reply!

 

Mine is a D630 with intel gfx. I used the myHack + EDP method and have used settings in the pinned thread - basically OSXLatitude was the only source of information I used to build the machine!

 

It defaulted to 32bit OSX so I used chameleon wizard to set it to run in 64bit and it now acknowledges the 8GB memory and runs much better as a result. Just sleep/hibernate doesn't work unless I change it back to 32bit.

 

I've tried changing the 'pmset -g' the hibernate mode value between 0 and 1 with no change in the machines behavior.

 

Thanks

Tim

 

Link to comment
Share on other sites

  • Administrators

I'm not sure about this, but maybe the SleepEnabler kext is 32bit only. You could try to run your D630 without NullCPUPowerManagement and without SleepEnabler to see if it makes any difference. In fact, I'll try it myself...

 

2 off-topic comments:

- I guess you're running in 64bit kernel mode without graphics support (Apple dropped 64bit X3100 kexts after 10.6.2). Yet, you find the system to run much better???

- You kind of hint you get 8GB RAM support only with 64bit kernel. I've no experience on the matter but I would have expected 8Gb to be supported regardless of the kernel mode (OS X does not operate like Windows).

Link to comment
Share on other sites

  • Administrators

I've done some checkings and tests with 64bit mode on my D630 X3100 HiRes with Lion 10.7.5:

  • NullCPUPowerManagement + SleepEnabler kexts are 32/64bit
  • I can boot 64bit mode kernel with "-force64" boot flag (unchecking 32bit in boot plist was not sufficient)
  • in 64bit kernel mode, I have no graphics support as expected (and I loose keyboard + trackpad too -> 'have to use USB input devices)
  • in 64bit kernel mode, I can put laptop to sleep and it will wake Ok, but always with a black screen (-> 'have to reboot!)
  • no boot plist option changed that wake behaviour (darkwake, npci, ...) in 64bit kernel mode
  • no change either, when booting with or without NullCPUPowerManagement + SleepEnabler (although I did experience the odd KP without them)

 

Without graphics support the laptop certainly feels sluggish (very obvious when double clicking on the HDD icon to open up the finder window).

 

To make sure you run in 64bit kernel mode, open About this Mac -> More info... -> System Report -> Software. Check the penultimate line that reads "64bit kernel and extensions". It'll say Yes or No. If you uncheck "32bit" option in Chameleon boot plist but do not select "force64", the D630 still boots in 32bit kernel mode.

Link to comment
Share on other sites

 Share

×
×
  • Create New...