Jump to content

I must be dumber than a mule


Recommended Posts

Hello lads, i have no idea what i am doing wrong, i have a dell D630, intel video. Changed the BIOS settings to what is recommended here. Tried with both myhack and nawcoms cd to boot the retail snow leo dvd. At the point where the installation of snow leo should begin, the screen goes black. And thats it. Not sure what or where is the problem. No kernel panics. Just a black screen. Any suggestions for a clueless noob?


BIOS rev is A18

Link to comment
Share on other sites

  • Administrators



You can't boot the retail SL DVD with myHack, only with ModCD. I guess you probably have a HiRes 1440x900 model, hence black screen right at the point where the boot completes and the Mac OS X installer/desktop should appear.


Nothing to worry about, this is to be expected...


There are 2 things you can do with Nawcom's ModCD (in the absence of ModUSB)

  • copy the DSDT from our D630 X3100 HiRes bootpack to a USB key, plug that key in and somehow load when you select your Retail DVD (find which HDD is it and use boot option "DSDT=hd(,)/DSDT.aml)
  • use an external screen and press F8 during laptop POST so that display is on external screen at ModCD bootup and at Retail DVD boot up. Upon DVD load completion, the external display will go dark and the built-in LCD will be activated and show the installation screen.


Upon SL installation, you'll be in the same situation so use external display again for 1st reboot. Afterward, just copy the D630 X3100 HiRes DSDT to /Extra and it'll fix things for good.


At that stage, you'll probably be running SL with legacy kernel from Nawcom. This initial installation will not be fully complete and some of the hardware may not be fully functional. You could complete this and also run the vanilla Mach kernel with that installation. However, I would recommend that you start afresh from there with a full vanilla installation made with myHack + OSXL bootpack + fine-tuning with OSXL EDP tool.


What you should do from there is the following:

  1. using Disk Utility, make an image of your SL DVD
  2. download and install myHack 3.1.2
  3. download our bootpack for your D630 model (a folder called "Extra" should be created in your "download" folder)
  4. mount your freshly made SL image (you can simply double click on it)
  5. get a USB key of at least 8Go
  6. run myHack and opt for "Create 10.6 installer" and select your USB key as destination
  7. when asked for "Extra folder", dont choose "Generic" but "my own" and point to the bootpack folder you previously downloaded
  8. at the end, you will have a nice myHack SnowLeopard installer on your USB key


That was a 1st phase, so now you need to start again with a 2nd phase that will set you with our supported full Vanilla installation:

  1. reboot off that installer USB key and follow the installation process
  2. towards the end of the installation process, you'll again be asked for "Extra" folder. Do as before, i.e. select "my own" and point to "/Extra" of your USB installer
  3. on completion, you should be able to reboot straight into a fully bootable SL installation
  4. download our EDP package and install it
  5. If you're not prompted to run EDP, open up /Extra folder in the Finder and double click "edptool.command"
  6. in EDP, click "Config" button in top menu, then select "build from model database" in left column
  7. from there on, choose your particular model and do a system build using the recommended/default settings


Good luck.

  • Like 1
Link to comment
Share on other sites

Hello again, so after  many tries, this is what i did and how things stand:


1.- Extract the HD from the D630

2.- Format in windows 7, insert the DSDT.aml file from the bootpack in the HD.

3.- Reinsert the HD, boot with modCD.

4.- Insert the retail SL DVD,  insert the command DSDT=hd(<x>,<y>)/DSDT.aml

5.- SL install begins, screen OK, installation completes OK.

6.- After install, D630 reboots, no video again.

7.- Remove HD again, on virtualbox SL, copy DSDT.aml to the extra folder.

8.- Reinsert HD, boot D630, SL loads OK! 

9.- install and run EDP, EDP informs all is OK

10.- Reboot, kernel panic.


Any ideas as to why did EDP crashed the install? Also i do not know how to read / interpret what the kernel panic is trying to tell me, what should i look for? thanks again!

Link to comment
Share on other sites

  • Administrators

:excl: I take it you did not literally enter "DSDT=hd(,)/DSDT.aml", did you? :blink:


You went Ok up to the point where you decided to run EDP without following the instructions posted above! I never said to run EDP on the ModCD installation, which will not work as you experienced. I clearly stated that you had to create a myHack installer after you got SL loaded with ModCD and proceed with a fresh SL installation with the myHack installer.


Try again and follow the process listed above... rigorously!

Link to comment
Share on other sites

Another strange occurrence. I Just created the myhack installer USB drive, added the extra folder, inserted a new NTFS drive on the D630 (so i do not lose the working SL hard disk). Computer keeps bootlooping (after the dell logo, all i can see i text line: boot0= done and then it restarts). USB drive was partitioned, at first, as MBR, then as GUID, same result. Any suggestions?

Link to comment
Share on other sites

  • Create New...