Jump to content

Dell XPS 720 Mountain Lion


Agrerald
 Share

Recommended Posts

Hi Guys,

 

I installed OS X Mountain Lion and  Lion on my Dell XPS 720. 

 

Current status:

Installing Lion using Myhack works. Installing Mountain Lion using Myhack works now.

 

What works:

Sound: works with VoodoHDA

Ethernet: works with BCM5722D kext

Chipset: doesn't work oob need ApplenForceSata kext

My Graphics card: works oob with ML and Lion with efi string

Almost everything works

What doesn't work:

Sleep will never work on an pc with a nforce chipset.

Sata DVD Drive only works in Lion when booted in 32-bit mode, because the ApplenForceSata kext doesn't have sata dvd drive support in 64-bit mode.

 

 

Specs:
Cpu: Intel® Core™2 Quad Q6600 @ 2,4 GHz

Memory: 8GB DDR2 800 MHz

My Graphics Card: Club3D Geforce GTX 550 Ti 1536mb DDR3

Ethernet: Broadcom BCM5754

Chipset: nVidia nForce 680i SLI

 

 

My Extra folder

Dell XPS 720 Extra.zip

 

 

Update

 
I removed some kext from my extra folder and move BCM5722D kext to E/E
 
New extra folder
 

Kext in S/L/E:

AppleHDAdisabler

 

Update 2

 

Installing Mountain Lion using usb works now.

Link to comment
Share on other sites

  • Administrators

Great, thanks for your work. We can probably work something out for graphics under Lion with a DSDT patching (graphics injection). Same goes for sleep: a DSDT patch could fix it.

 

Did you try with/without SleepEnabler?

Link to comment
Share on other sites

Sleep will never work on an pc with a nforce chipset. 

"It is primarily the need for the AppleNForceATA.imk64bit.kext in /Extra/Extensions/ and nForceLAN.0.64.5.kext in /System/Library/ Extensions/, as well not being able to use a SleepEnabler.kext and having issues with sleep that distinguishes nForce chipset + Intel CPU MOBOs from non-nForce chipset + Intel CPU MOBOs rather than the basic procedures for installing OS X........."

Source

 

I got my graphics working under lion without natit or nvenabler. I used a efi string and now it works.

Link to comment
Share on other sites

 Share

×
×
  • Create New...