Jump to content

E6430 HDMI Audio and a couple other items


azub
 Share

Recommended Posts

Hi everyone!  Thanks so much to everyone who contributes to get all of our machines up and running!

 

I recently got my E6430 machine up and running with this post here: https://osxlatitude.com/index.php?/topic/2327-dell-latitude-e6430/. My specs are exactly the same except I have a newer bios.

 

I have a few things that I cannot get working.  Can anyone assist?

 

1) HDMI Audio.  I cannot get it to work.  Audio continues to come out of my laptop speakers and there is no setting to change.  I usually hook my machine up to the TV and watch TV.  In Win 7, audio/video was passed through to the TV and an optical cable was plugged in from the TV to my speakers.  I guess the functionality isn't there?

 

2) USB 3.0 stops working after a couple of reboots.  I used genericusb.kext (of which I had to install the manual method, no other tool would work) and USB 3 seemed to be working.  Since then it has stopped working, and the machine continues to freeze.  When this happens, should I just attempt manual install again?

 

3) Bluetooth? Does it function?

 

4) Dual Boot - Seeing as I followed the above post to get my machine up and working (along with the change to Dell wireless card) how would I go about now dual booting with Windows 7?  I understand I can shrink my drive, however is there a guide that coincides with the above post?

 

5) Cleartype - The video on my TV doesn't look nearly as good as with Windows 7. (through HDMI) I guess this is the best I can expect.

 

It is a lot I know!  Thank you so much in advance.

 

Link to comment
Share on other sites

  • Moderators

Hi everyone!  Thanks so much to everyone who contributes to get all of our machines up and running!

 

I recently got my E6430 machine up and running with this post here: https://osxlatitude.com/index.php?/topic/2327-dell-latitude-e6430/. My specs are exactly the same except I have a newer bios.

 

I have a few things that I cannot get working.  Can anyone assist?

 

1) HDMI Audio.  I cannot get it to work.  Audio continues to come out of my laptop speakers and there is no setting to change.  I usually hook my machine up to the TV and watch TV.  In Win 7, audio/video was passed through to the TV and an optical cable was plugged in from the TV to my speakers.  I guess the functionality isn't there?

 

2) USB 3.0 stops working after a couple of reboots.  I used genericusb.kext (of which I had to install the manual method, no other tool would work) and USB 3 seemed to be working.  Since then it has stopped working, and the machine continues to freeze.  When this happens, should I just attempt manual install again?

 

3) Bluetooth? Does it function?

 

4) Dual Boot - Seeing as I followed the above post to get my machine up and working (along with the change to Dell wireless card) how would I go about now dual booting with Windows 7?  I understand I can shrink my drive, however is there a guide that coincides with the above post?

 

5) Cleartype - The video on my TV doesn't look nearly as good as with Windows 7. (through HDMI) I guess this is the best I can expect.

 

It is a lot I know!  Thank you so much in advance.

Hi azub,

Welcome to the forum.

 

1) HDMI Audio should work, but it doesn't autodetect the first time. Go to the audio preference and change output to HDMI

Screen Shot 2013-06-07 at 6.02.14 PM.png

 

2) USB 3.0 - Check this thread, another member mentioned it works better here

 

3) Bluetooth - Check here, you might have to check if it uses the same ID

 

4) Dual Boot -

  • Create a fat partition from OSX, adjusting partition size, reboot with Windows 7 disk.
  • Select the fat partition to install, format it to NTFS and finish the build. 
  • Reboot, it'll automatically boot to Windows, finalize and update drivers...etc
  • Reboot with OSX USB Installer, select the Mac OSX
  • Boot into OSX, launch the Chameleon wizard (download it if you haven't already). 
  • In Chameleon, under Install "Install method", select Boot0hfs, and click on Install below. 
  • Reboot without the USB installer, when you see the boot screen, hit enter and you'll see the option to choose between OSX and Windows 7

Screen Shot 2013-06-07 at 6.21.00 PM.png

Good luck!

  • Like 1
Link to comment
Share on other sites

  • Moderators

EDP installed and run successfully but boot into only HDMI display with the internal LCD black.

It has added a few "Digital Output" to my sound setting panel but none of them leads to HDMI Audio still.

Do you have the same spec as azub too?

Is your LCD resolution 1366x768 or higher?

Link to comment
Share on other sites

try looking in edpweb and in the fixes selection, select fixspdisplays_display. 

 

the jist of it is basically this: This fix handles a name issue under display prefs. (copied and pasted from the app)

 

so it should fix all the missing stuff too? Also what if you run MyFix on your hard drive? just a couple questions

Link to comment
Share on other sites

To Jack Lo:

Sorry for not mentioning my spec.

I have only HD4000, no nVidia.

And I have resolution 1600x900, not 1366x768.

 

To MacMacMac:

Tried fix spdisplays_display and doesn't work.

I saw EDP runs myFix in Step 6 during build so that I didn't run it again.

 

Thank you both!

Link to comment
Share on other sites

  • Moderators

To Jack Lo:

Sorry for not mentioning my spec.

I have only HD4000, no nVidia.

And I have resolution 1600x900, not 1366x768.

 

To MacMacMac:

Tried fix spdisplays_display and doesn't work.

I saw EDP runs myFix in Step 6 during build so that I didn't run it again.

 

Thank you both!

Download and Extract file to E/E and run myFix. Reboot and update your result here.

AppleIntelFramebufferCapri.kext.zip

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...