Jump to content

[How To] Dell Inspiron17 3721 - Fully Working


hibernian56

Recommended Posts

This is my first guide, although I have built several hackintosh's following other peoples guide, I thought it might be a good time to give back to the community as I found NOTHING for this great bit of kit online. So bear with me...

 

I did this build for a friend of mine, but I would highly recommend the hardware, it's an excellent laptop.

 

Dell Inspiron 17 (3721)

17.3" HQ display

Core i3

4gb

500gb HD

 

Working:

OSX 10.8.3

Webcam

Graphics

Sleep

Ethernet

Battery indicator / charge level

Wifi & Bluetooth (requires changing the mini card under the keyboard, a 2 minute job)

HDMI out (no idea can't check)

Sound (Using VoodooHDA 2.8.4)

Trackpad (No gestures as VoodooPS2 won't work after sleep)

 

Very stable for a couple of days now.

 

Method:

Bios Preparation:

1. Make sure the laptop is plugged in...

2. Power on and hold down F2 to enter BIOS setup

3. Use the arrow keys to go to the Boot menu

4. Use the down key to move to Secure Boot and press enter

5. Select Disabled

6. Use the down arrow to move to Load Legacy Option Rom and press enter

7. Select Enabled

8. Use the down arrow an move to Boot List Option and press enter

9. Select Legacy

10. Press F10 to save and exit

11. Let the machine reboot and press F2 at the Dell logo

12. Use the arrow keys to go to the Boot menu

13. Use the arrow keys to move to LEGACY BOOT and press enter

14. Use the arrow keys and select Hard Drive

15. Press F5 or F6 to change it's position to top of the boot order

16. Press F10 to save and exit

17. Switch off the laptop for now

 

Done.

 

 

OS Preparation:

1. Get a friend with a working Mac or Hackintosh

2. Create a standard OSX installation USB key or USB hard drive using the many guides available...

3. Very Important: Copy the GenericUSBXHCI.kext file to /Extra/Extension folder on the USB installation Drive, otherwise you will get a number of different cryptic errors, most notably "still waiting for root device"

4. Make a folder called ++Tools on the USB installation drive

5. Copy all of the attached files into this folder. This will save a lot of pain later

 

 

Done

 


WIFI Preparation:

1. Buy an Atheros AR5B197 from eBay (or AR5B195 works too and is apparently cheaper)

2. Follow this guide to remove the keyboard http://www.insidemylaptop.com/disassemble-dell-inspiron-17r-n7110/

3. Disconnect the two antennae and whip out the old WIFI card, its held in with one screw

4. Put the new card in, secure with the screw and connect the antennae

5. Replace the keyboard

 

Done

 

 

Installation:

 

NOTE: This will completely erase your Windows 8 installation, there is no going back from here. Be warned, be careful.

 

1. Connect the USB installation drive to the laptop

2. Turn on the laptop

3. Press F12 at the Dell logo

4. Let the installer load to the Welcome screen

5. Get a cup of coffee (me I prefer beer, but I'm Irish)

6. Select your language and click the small arrow at the bottom

7. At the top of the screen you will see a menu for Utilities click it

8. Click on Disk Utility

9. Your main drive should say 500.11 GB etc. and be coloured grey (it will have several partitions listed below it), the USB drive is coloured orange

10. Click on the Main drive (the top grey drive)

11. Click on the tab to the right where it says Erase

12. Make sure Mac OS Extended (Journaled) is selected

13. Change where it says untitled and name the new drive Macintosh HD

14. Click on the Erase... button

15. On the menus at the top click where it says Disk Utility

16. Click where it says Quit Disk Utility

17. Install OS X should appear again, click the Continue button at the bottom

18. Click Agree to the Software Licence Agreement. If you are bored read it.

19. You should see a big picture of you Macintosh HD drive, click on it, a green arrow should appear

20. Click Install button at the bottom

21. Get another cup of coffee / beer. This takes about 20 minutes.

22. If the screen goes grey during installation, don't panic its just the screen saver, press the spacebar once to check progress.

23. When the machine restarts select the Macintosh HD drive and press enter

 

Done

 

 

System Set Up:

 

1. Hopefully if all went well you should see the Welcome screen

2. Select your country and press Continue

3. Sect your keyboard and press Continue

4. Select My computer does not connect to the internet and press Continue

5. When you see Your Internet Connection just press Continue

6. A warning pops up, just press Continue

7. The Transfer Information... screen pops up, select Not Now and press Continue

8. Agree to the Software Licence Agreement

9. Name your computer and user account then press Continue

10. Select your country and press Continue

11. Select Start Using Your Mac

 

Done

 

Post Installation

 

NOTE: Using Chameleon caused huge issues, especially with the CPU not being discovered. I edited this guide to instal chimera (chameleon, stolen and rebranded) (chameleon, stolen and rebranded) from multifail, once I did that EVERYTHING worked perfectly.

 

1. Nearly there.

2. Click on the desktop, and then under the Finder menu at the top click Preferences...

3. Select Hard Disks under Show these items on the desktop

4. Go to the ++Tools folder on your USB installation disk

5. Download multifail and double click the multifail.pkg file

6. Go to the Boot Loaders section and install chimera (chameleon, stolen and rebranded) (chameleon, stolen and rebranded) select nothing else. This will instal the boot loader and quit when finished.

7. In the ++Tools folder double click the ShowHiddenFiles app and select Show Special Files quit the application

8. Copy the Extras folder in the ++Tools folder of the USB installation drive to the root of Macintosh HD

9. In the ++Tools folder double click the Kext Wizard icon and click on the Installation tab

10. In the S/L/E folder inside the ++Tools folder and drag its contents onto the Kext Wizard window

11. In Kext Wizard click where it says System/Library/Extensions and click Install

12. Type in your password and press OK give it a minute or so

13. When it says Done click OK and click on the Maintenance tab

14. Select all 6 boxes, make sure Macintosh HD is selected and press Execute. This takes about 10 minutes. It asks you for your password towards the end, enter and press OK

15. Get a beer. Quit Kext Wizard

16. Eject your USB installation drive

17. Fingers crossed, and press the power button select Shutdown

 

Done

 

 

Final Step - Remove boot0: error

 

1. We need to do this final step due to the way the hard drive has been set up day 1

2. Restart and hold down F12 for Boot Options and select USB Storage Device and hit enter

3. Select the USB Installation drive and press enter

4. Select your language and then select Disk Utility from the Utilities menu at the top

5. Unmount Macintosh HD and quit Disk Utility

6. Select Terminal from the Utilities menu at the top

7. In the Terminal window type in diskutil list

8. Locate Macintosh HD and copy the identifier beside it, mine was disk0s2 yours will be in a similar format

9. In Terminal change directory to the ++Tools folder i.e. type in cd /Volumes/Install OSX/++Tools

10. In Terminal type ls to verify you can see the boot1h file

11. In Terminal type dd if=boot1h of=/dev/identifier

12. Restart the laptop

 

Done

 

Sound

 

I have used Voodoo 2.8.4 and got sound working. This MUST be done in conjunction with using the chimera (chameleon, stolen and rebranded) (chameleon, stolen and rebranded) boot loader rather than Chameleon.

 

DSDT

 

I have attached working DSDT & SSDT files as part of the Extra Folder installation. A BIG THANK YOU to Dinesh for his help here.

 

EDITS:

Made a small edit to the WIFI section to avoid confusion.

++Tools.zip

Link to comment
Share on other sites

  • Replies 66
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Yeah, the Trackpad was too sensitive at first. I tried installing "SmoothMouse", and it helped with the sensitivity a little, but there was still no way to shut of the annoying "Tap-to-Click" feature. Since I prefer to use a small travel mouse with my laptops, I can live without the Trackpad working "perfectly". (See below for what seems to be a Trackpad "fix").

 

I just did a second Dell 17-3721 Dual-Boot system (Mac OS-X & Windows 8). I decided to make it easier to do the Mac install, so I "cloned" my other Dell 17's Hard Disk using CCC (Carbon Copy Cloner). I couldn't get it to work at first - it wouldn't show the chimera (chameleon, stolen and rebranded) Bootloader! Then, I went back and performed the steps from your Guide shown here titiled "Final Step - Remove boot0: error" and PRESTO! It worked perfectly. When installing a Dual-Boot system with Windows 8, it is best to use Disk Utility to create 2 partitions, with the first being formatted for "DOS", and the second being formatted for "OS-X Extended (Journaled)". Then, Install Windows 8 to the first Partition, as Windows 8 creates 2 Partitions during the Install - the first one (only about 250Mb) is labeled "System Reserved", and is the actual "UEFI" Partition, and the second is the Windows 8 "Primary" Partition. This is important because when you install OS-X, it uses the UEFI Partition for chimera (chameleon, stolen and rebranded) - that's where it "lives". Interestingly, when all is installed properly for both Systems, the chimera (chameleon, stolen and rebranded) Boot Screen shows THREE icons: "System Reserved", "Windows NTFS", and "OS-X". In order to boot to Windows 8, you have to select "System Reserved". (That's where Windows 8 writes its "Bootloader" info.) If you select "Windows NTFS", it doesn't "crash" or do anything bad, it just loops back to the chimera (chameleon, stolen and rebranded) Bootloader screen. The OS-X selection will actually be labled with whatever you chose to label your Mac OS-X Partition. Since I had successfully installed the 10.8.5 update, I labeled mine "OSX 10.8.5". (NOTE: I downloaded the "10.8.5 Combo-Update" and ran it, then ran the chimera (chameleon, stolen and rebranded) installer again BEFORE re-booting, just to be safe. That said, on re-boot, I found it had "broken" USB - see fix below).

 

SIDEBAR: When I installed the OS-X 10.8.5 update, it "broke" USB! In order to fix it, I had to use the VERY SLUGGISH (at this point) Trackpad, to re-install your provided USB Kext(s), by dragging them to the "Kext Utility" icon on the Dock. (I keep it on the Dock during these installs, as it is necessary for the proper installation of the many Kext "patches"). After re-boot, USB was back to normal. Another interesting and WELCOME "side-effect" of updating to 10.8.5 is that it seems to have "fixed" the Trackpad - it now has a much more "subdued" speed, and that pesky "Tap-to-Click" feature is GONE! (Before the 10.8.5 update, the Trackpad "System Preferences" Pane showed "No Trackpad Found". Now, all of the controls one would find on a "regular" Mac are there. TWO-FINGERED SCROLLING WORKS TOO).

 

I have not thoroughly tested the USB 3 ports to see if they're really "running at USB 3 speed" - I just know that whatever I plug into them seems to work fine. (USB 3 peripherals are still somewhat rare anyway).

Link to comment
Share on other sites

Mike,

 

I forgot to mention, I got the sleep working (kinda).

 

If you get a free little app called "Sleep Please" from MacUpdate it allows sleep to work. BUT you have to allow the machine to actually go to sleep, I just set the time to 2 minutes, once it goes to sleep, this little app keeps it there, no more drained battery. Pressing the sleep button or selection "sleep" still results in the machine waking up almost immediately.

 

I would love to know how you managed to get the Trackpad pref pane working, no matter what I do I can't get it to show up. Can you do a .zip of your S/L/E folder? Very strange. 

 

I use gestures all the time, especially scrolling etc.

Link to comment
Share on other sites

On the second Dell 17-3721, I was able to get the Trackpad working, except unlike the first one I did, I can't seem to get rid of the "Tap-to-Click" feature! I used your "SmoothMouse" Kext in combination with the okTrackpad.prefPane. With them both installed, when I click on the Trackpad in System Preferences, it gives me ALL of the standard Trackpad settings one would see on a "regular" Mac, except on the second Dell 17 the "Tap-to-Click" feature can't be turned on & off - it CAN be on the first Dell 17. Weird! Of course, I'm not as smart on this stuff as many of the folks who've figured out how to get "Hackintosh" systems to work, so I'm not knowledgeable on all of the Kexts that affect the Trackpad and other I/O devices. Also, when I open "System Configuration, both of the Dell 17-3721's show "iMac early 2001". I know this is related to the SMBIOS file. Question is, should I try to change it so it shows "MacBook Pro" with some "vintage" (year) or leave well enough alone? Have you tried installing a different SMBIOS file? I have another problem - I didn't test it before now (MYBAD) but my WebCam isn't working either! When I open FaceTime, I get a window, with the camcorder icon with the diagonal line through it. RATS!

Link to comment
Share on other sites

I used the MacBookPro 9.2, all works fine. I'm nearly sure I had a copy of my smbios in the first post.

 

Also, does the web cam work in Photobooth? I never used FaceTime, but my webcam works. Is it listed under About this Mac / System Report? In Kext Wizard could you save the list of loaded kexts for me? Kext Wizard > File > Save list of loaded kexts into txt file.

 

Did you loose your bluetooth after the supplemental update?

 

OK, I got the trackpad working using this guide...

http://www.tonycrapx86.com/hp-probook/75649-new-voodoops2controller-keyboard-trackpad.html

And I used the updated FakeSMC from here...

https://github.com/RehabMan/OS-X-FakeSMC-kozlek

 

Will update the first post tomorrow with these updated files.

 

Almost 100% working now!!! Just the Bluetooth to sort.

Link to comment
Share on other sites

I appreciate your efforts and tips. Most of my troubles are due to the fact that I upgraded to 10.8.5 - aren't you still running 10.8.3? I booted from my 10.8.4 external backup USB HD, and the WebCam opens right up in FaceTime AND PhotoBooth. My Bluetooth isn't working (in 10.8.5) either.

 

So here are the 3 things that need fixing in 10.8.5:

 

- Built-In WebCam

- Built-In SD Card Reader

- Bluetooth

 

I hope these are only Kext issues, and that I (we) can eventually find the ones that work in 10.8.5

 

Still haven't figured out why I can't turn off "Tap-to-Click" on one Dell in 10.8.5 but not the "cloned" one....

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...