Jump to content

ML crashes before graphical interface, tried about everythin


chasingcharlie
 Share

Recommended Posts

I am desperate. I’ve tried two motherboards and two processors. I can never get to the graphical install interface on ML. I have gotten to the point of “waiting on root device†but I’m not able to get there now. Whatever I try: multiboot (chameleon, stolen and rebranded), crackwalk or myhack, each reboots when it gets to that point of loading the graphical interface. Even though I use the –F switch, it does the same thing and I can never see the error. It doesn’t “halt†where I can read the messages.

First motherboard & chip: z68ap-d3 (2.0), G630 Sandy Bridge 2.7 GHz, asus 210 Ge Force 512 MG (video). Second motherboard: B75M-D3P, i3 2120 3.3 GHz (video on board). Same results.

I have used about every switch I can find online (DSDT=no, GraphicsEnabler=no; -v, -x cpus=1 busratio=18; -v npci=0x2000 cpus=1 GraphicsEnabler=No; debug=8 ahcidisk=1; HPET, 64 bit, ACHI). I even flashed the z68ap motherboard. I have a working rig, using Snow Leopard that is “incompatible with ML.†I built that rig from scratch and had no problems. I have changed stuff in the BIOS trying to install ML until I’m almost blind. I have re-set to default settings and tried again.

I am willing to try anything that anyone suggests. I also have a MacBook Pro I can use to make stuff. Someone p l e a s e give me something different to try or do. I can do things in terminal in single user mode if someone will give me step-by-step directions.

Please help.

Link to comment
Share on other sites

Please post in a well organized mater so that people can follow what your specs are and what you have done. Second I can tell you have no understanding in regards to what the boot flags do so please review the following before continuing:

 

http://forum.voodooprojects.org/index.php?topic=351.0

 

There is a non fixable with this system:

 

GA-B75M-D3P

Intel I3 2120

HD2000 (Unsupported So Do Not Bother)

 

Looking at:

 

Gigabyte z68ap-d3

Intel Pentium G630

Asus Nvidia 210

 

Boot with myHack with the following flags:

 

-v GraphicsEnabler=No

 

Post a pic were it hangs showing the full screen. Also make sure you are not connected to a USB 3.0 port and are using a USB 2.0 port on the back of the system.

Link to comment
Share on other sites

I have the code; it is below if someone can help me figure out what to do next:

--Start code--

Creating RAM Disk for /Library/Keychains

 

Initialized /dev/rdisk12 as a 1024 KBHFS Plus volume

 

Using 64-bit bootcache playlist

 

BootCache Control: Unable to open /var/db/BootCache.playList: 2 No such file or directory

 

NVDANV50HAL Loaded and registered.

 

Previous Shutdown Cause: 3

 

Panic(cpu 0 caller 0xffffff80002b7bd5): Kernel trap at 0xffffff7f80b94806, Type 14-page fault, registers:

 

CR0: 0x000000008001003b, CR2: 0x0000000000000000, CR3: 0x000000000275a000, CR4: 0x00000000000206e0

 

RAX: 0x0000000000000000, RBX: 0xffffff80008e0ae0, RCX: 0x0000000000000000, RDX: 0xffffff8006209dc0

 

RSP: 0xffffff804774bdc0, RBP: 0xffffff804774bdd0, RSI: 0xffffff8000830ae0, RDI: 0x0000000000000000

 

R8: 0x0000000000000b90, R9: 0x0000000000000007, R10: 0x00000000000fb800, R11: 0x0000000000000000

 

R12: 0xffffff8006331200, R13: 0xffffff8006f73000, R14: 0xffffff8006f81d00, R15: 0xffffff8006f81d00

 

RFL: 0x0000000000010246, RIP: 0xffffff7f80b94806, CS: 0x0000000000000008, SS: 0x0000000000000010

 

Fault CR2: 0x0000000000000000, Error code: 0x0000000000000000, Fault CPU: 0x0

 

Blank line

 

Debugger called:

 

Backtrace (CPU0), Frame : Return address

 

0xffffff804774ba60 : 0xffffff80021d626

 

0xffffff804774bad0 : 0xffffff80002b7bd5

 

0xffffff804774bca0 : 0xffffff80002ce4ed

 

0xffffff804774bcc0 : 0xffffff7f80b94806

 

0xffffff804774bdd0 : 0xffffff7f80b94992

 

0xffffff804774bdf0 : 0xffffff7f80b95ac1

 

0xffffff804774be60: 0xffffff800063181b

 

0xffffff804774bea0 : 0xffffff800063133e

 

0xffffff804774bf30 : 0xffffff800062d2d0

 

0xffffff804774bf70 : 0xffffff8000631e99

 

0xffffff804774bfb0 : 0xffffff80002b26b7

 

(6 space indent) Kernel Extensions in backtrace:

 

(9 space indent) com.apple.driver.AppleIntelSNBGraphicsFB(8.0)[5E0862D0 – E39F – 3012 – 907B –[email protected]>0xffffff7f80bb4

 

fff

 

(12 space indent) dependency: com.apple.idkit.IOACPIFamily(1.4)[A35915E8 – C1B0 – 3C0F – 81DF – 5515BC9002FC]@0xffffff7f80782000

 

(12 space indent) dependency: com.apple.idkit.IOPCIFamily(2.7.2)[b1B77B26 – 7984 – 302F – BA8E – 544DD3075E73]@0xffffff7f80789000

 

(12 space indent) dependency: com.apple.idkit.IOGraphicsFamily(2.3.5)[803496D0 – ADAD – 3ADB – B071 – 8A0A197DA53D]@0xffffff7f80b500001

 

Blank line

 

BSD process name corresponding to current thread: Kernal_task

 

Boot args: boot-uuid=166A17E5 – 0945 – 330E – B0BB – B70CD4746495 id=*uuid –x –f –v npci=0x3000 GraphicsEnabler=No

 

Blank line

 

Mac OS version:

 

12C60

 

Blank line

 

Kernel version:

 

Darwin Kernel Version 12.2.0: Aug 25 00:48:52 PDT 2012; u root: xnu – 2050,18.25 -1/RELEASE_X86_64

 

System model name: iMac8.1

 

Blank line

 

System uptime in nanoseconds: 15947592933

Link to comment
Share on other sites

Again you are not following what I had asked you to do. You booted with:

 

–x –f –v npci=0x3000 GraphicsEnabler=No

 

Please boot as instructed and you have NO IDEA what you are doing in regards to boot flags so please do not experiment. With what you booted with it will never work. If you want help DO AS TOLD.

Link to comment
Share on other sites

This motherboard doesn't have built-in graphics. I'm using the Asus 210 Geforce.

There is an onboard vga setting but there is no "off" for it; just Enable if no EXT PEG, always enable and Auto. On anything but auto, it reboots rather than showing what stops the process. If there something I need to do in Myhack to change that?

thanks

charlie

GA-Z68AP-D3 (R2)

i3-2120-3.3. GHz

Asus 210 SL Geforce

Link to comment
Share on other sites

Under Advance BIOS Features:

 

Onboard VGA

Enables or disables the onboard graphics function. Auto

Allows you to set up a dual-display configuration in Windows 7 operating system. (Default) Enable If No Ext PEG

Activates the onboard graphics only when no PCI Express graphics card is installed. Always Enable

Always activates the onboard graphics, whether or not a PCI Express graphics card is installed. If you wish to set up a dual-display configuration, set this item to Always Enable.

 

You just needed to take it slower and look at all the menus.

Link to comment
Share on other sites

 Share

×
×
  • Create New...