Jump to content

OSX on D520 report


jan
 Share

Recommended Posts

Hi, first of all thanks for the great project. It's the best one I came across.

 

I used the D620SLV1.iso and retail Snow Leopard 10.6.0 to install OSX to my Dell Latitude D520 and then updated to EDP (1.8) and chameleon.

 

Everything seems to work except these :

 

- keyboard

 

only the alt modifier key works and is swapped with the command key (so no control and alt)

 

- ethernet

 

the BCM 440x card is detected, connects but never gets IP from DHCP (static IP doesn't help)

noticed that if I remove the DSDT.aml from /Extra and disable some kexts which would otherwise kernel panic then the ethernet starts working. But it's not a solution because removing the dsdt the only working thing is the ethernet card :)

 

- wifi

 

my latitide came with intel 3945, which is not supported, or at least not with encryption which makes it kinda useless, so I decided to use original AirPort card from my Mac Mini, which is not needed there.

 

It is an AirPort Extreme with atheros chip AR5BXB6 [PCI 168c:001c]

As recognized in Linux :

0c:00.0 Ethernet controller: Atheros Communications Inc. AR242x / AR542x Wireless Network Adapter (PCI-Express) (rev 01)

 

Well, i suppose this card should be working OOB, since it's an original Apple part, but no matter what I do or which version of SL I use it just refuses to work.

 

I have tried SL 10.6.0 to 10.6.7 with same results.

 

kernel.log from 10.6.0 :

 

Error: offset_0x100 = 0xffffffff

6/15/11 6:20:18 PM kernel start [/sourceCache/AirPortDriverAtheros5424/AirPortDriverAtheros5424-411.19.4/src/common/lmac/ath_dev/darwin/AtherosController.cpp:1149] load failed

6/15/11 6:27:45 PM kernel start [/sourceCache/AirPortDriverAtheros5424/AirPortDriverAtheros5424-411.19.4/src/common/lmac/ath_dev/darwin/AtherosController.cpp:1149] load failed

6/15/11 6:30:38 PM kernel start [/sourceCache/AirPortDriverAtheros5424/AirPortDriverAtheros5424-411.19.4/src/common/lmac/ath_dev/darwin/AtherosController.cpp:1149] load failed

 

kernel.log from 10.6.7 :

 

Jun 15 19:19:04 localhost kernel[0]: Error: offset_0x100 = 0xffffffff

Jun 15 19:19:04 localhost kernel[0]: start [/sourceCache/AirPortDriverAtheros9380/AirPortDriverAtheros9380-424.14.5/src/common/lmac/ath_dev/darwin/AtherosController.cpp:962] load failed

Jun 15 19:19:04 localhost kernel[0]: Error: offset_0x100 = 0xffffffff

Jun 15 19:19:04 localhost kernel[0]: start [/sourceCache/AirPortDriverAtheros5424/AirPortDriverAtheros5424-411.19.4/src/common/lmac/ath_dev/darwin/AtherosController.cpp:1149] load failed

Jun 15 19:19:04 localhost kernel[0]: Error: offset_0x100 = 0xffffffff

Jun 15 19:19:04 localhost kernel[0]: start [/sourceCache/AirPortDriverAtheros9380/AirPortDriverAtheros9380-424.14.5/src/common/lmac/ath_dev/darwin/AtherosController.cpp:962] load failed

Jun 15 19:19:04 localhost kernel[0]: Error: offset_0x100 = 0xffffffff

Jun 15 19:19:04 localhost kernel[0]: start [/sourceCache/AirPortDriverAtheros5424/AirPortDriverAtheros5424-411.19.4/src/common/lmac/ath_dev/darwin/AtherosController.cpp:1149] load failed

 

If I boot to Linux using the same machine, the card works without problems, is recognized and connects. Now if I put the disk from the latitude to my Mac Mini together with the card, it boots without problem and recognizes the card as AirPort Extreme.

 

My guess is that it could be some PCI express addressing issue, but have no idea how could it be fixed. So please, could anybody give me some pointers ?

 

lspci_n.dellbook.txt

Link to comment
Share on other sites

hey fella why don't you download the kext helper and the latest version of mac os snow leopard. via a pendrive of course, cause you don't have internet. and then search in our friend google(o' course again) and search for kexts that are similar for the one that you're looking for, because it seems that hackintoshes works with similar cards like same "family" or "type".

wish it helps dude

Link to comment
Share on other sites

 Share

×
×
  • Create New...