Jump to content

Lenovo E330 kernel panic after EDP install


Recommended Posts



I followed the instructions on how to install Mavericks on my E330, as I noticed this model was listed in your EDP database. Created the bootable USB incl the extra's, installed OS X Mavericks as instructed. It starts up fine, although the touchpad was very jumpy. Solved that by installing an external usb mouse. After the first installation I installed the EDP and fired it up. Selected the pack for the Lenovo Thinkpad E330, accepted all defaults to install and clicked Continue. It installed and built all stuff, after which I reboot the laptop. It won't start again, it stops with a kernel panic.


panic (cpu 0 caller .....) Kernel trap at xxxx, type 13=general protection

Kernel expections in backtrace



I tried rebooting with the -v -x switches, sadly no change, it will not boot up.

Any suggestions how to fix this?

Link to comment
Share on other sites

Seems like its missing SSDT files (or) kernel cache is broken. Try to boot using all these flags 'UseKernelCache=No DropSSDT=No GeneratePStates=Yes GenerateCStates=Yes'. If you still can't boot then try to boot from myHack USB installer and choose the installed OSX to boot with the above flags and see.


After booting, try to check Extra folder for SSDT files and run myFix to generate kernel caches again. If you still have problems then let me know.

Link to comment
Share on other sites

Hi again,


- Tried the flags, no boot

- Tried the flags from the USB installer, no boot

- Did a clean reinstall, downloaded the bootpack and copied the Extra folder to the \Extra folder of the harddrive, replaced the existing files

- Run EDP, selected the Thinkpad E330, accepted all defaults, did a build

- Reboot --> panic (again)


Are there any files, debugs, dumps etc I can send to help solve this? I noticed my E330 is a slightly different model from the one listed in the database, maybe that could be the cause? 

Link to comment
Share on other sites

  • Create New...