Jump to content

Blinking Cursor / Boot loader issue after install


Recommended Posts


I am hoping that someone can provide me with some assistance. I was able to successfully install OSX Mavericks on my D630 per instructions at the top of this page. Unfortunately, after completing the installation, i receive an black screen with a blinking cursor. I researched this and came across this to remedy:


Issue: After passing various installation obstacles, the bootload hangs at a blinking cursor "_" .


Boot with the DVD and use -s at boot load.

sudo -s
-e /dev/rdiskX --->(X is the number of your HD, if you have only on its 0)
f X
--->(X is the number of the partition where you installed Leopard)

Mentioned with Kalway release: the bootloader does not like seperate disk names. Use a single word as name.

Release 10.5.2 R2 has a problem booting if EFI and GUID are choosen



I only have one hard disk and 1 partition on the disk. I tried the fdisk command above and it gave me an error message when I tried to replace X with 0. I am new at all of this. How do I find the HD and partition numbers per the instructions above?


here is the error message:

fdisk: could not open MBR file /usr/standalone/i386/boot0: No such file or directory


Thanks- Jeff

Link to comment
Share on other sites

  • Administrators

Those messages refer to some old Leopard distro, so ???


If you're trying to install Mavericks on a HDD that had that distro in the past, it looks as if you need to wipe it out completely beforehand. Use myHack + the downloaded Mavericks app + OSXL bootpack to make your USB installer. When you boot your installer, go to Utilities->Disk Utility and delete any existing partitions on the drive and create a brand new GUID partition that you'll format OS X extended (journaled).


Do not use the MBR patch at the end of the Mavericks installation. You only need the MBR patch if you install on a disk with existing MBR partition table and you lust use a different patch than the defective one provided with myHack v3.3.1.

Link to comment
Share on other sites

I tried all the steps again (recreated bootdisk, verified BIOS settings, and repartitioned the hard drive) with the same results - the flashing cursor at reboot. The only place where I deviated from the instructions is that during the USB boot disk creation, MyHack does not prompt me to use the generic Extra folder, so I copied the Extra folder from the bootpack onto the USB boot disk and ran myFix against the USB installer. Could that be my issue?

Link to comment
Share on other sites

  • Create New...