Jump to content
Leon

Ubuntu/Debian: 14e4:43b1 Broadcom Corporation Device 43b1 (rev 03)

Recommended Posts

Hi,

This guide will show you howto get the BCM4352 card working in Ubuntu/debian.

Pre-guide stuff:
 1. Dont install the STA driver, that one wont work


Step 1)
Install required packages: apt-get install fakeroot dkms

 

 

Process:

 

64 bits:

cd
mkdir b43b1-6.30.223.141
wget http://www.broadcom.com/docs/linux_sta/hybrid-v35_64-nodebug-pcoem-6_30_223_141.tar.gz
tar xvzf hybrid-v35_64-nodebug-pcoem-6_30_223_141.tar.gz -C b43b1-6.30.223.141

32bits:

cd
mkdir b43b1-6.30.223.141
http://www.broadcom.com/docs/linux_sta/hybrid-v35-nodebug-pcoem-6_30_223_141.tar.gz
tar xvzf hybrid-v35-nodebug-pcoem-6_30_223_141.tar.gz -C b43b1-6.30.223.141

For 64 & 32 bits:

cd b43b1-6.30.223.141
touch dkms.conf
pico dkms.conf o gedit dkms.conf

Paste this (without lines) :
----------------------------------------------
PACKAGE_NAME="b43b1"
PACKAGE_VERSION="6.30.223.141"
CLEAN="make clean"
MAKE="make"
BUILT_MODULE_NAME="wl"
BUILT_MODULE_LOCATION="./"
DEST_MODULE_LOCATION="/updates"
----------------------------------------------
save and exit

cd ..
sudo mv b43b1-6.30.223.141 /usr/src/b43b1-6.30.223.141
cd /usr/src/b43b1-6.30.223.141
sudo dkms add -m b43b1 -v 6.30.223.141
sudo dkms build -m b43b1 -v 6.30.223.141
sudo rmmod wl
sudo dkms install -m b43b1 -v 6.30.223.141
sudo modprobe wl

 

Reboot computer

Add module wl in /etc/modules to load it at boot time if it doesn't work at reboot.

Enjoy ;)

Share this post


Link to post
Share on other sites

Hi Leon,

 

I am quite new to the Linux word and I have some problem connecting with the WiFi card BCM4352 on Ubuntu 14.04 64bit.

Even if the password is 100% correct, the system continue to ask me for the password in order to get the access to the wireless network.

Looking on the web it seems to be a problem related to the Broadcom driver, so I would like to test your solution.

 

Since I have already installed the STA, have I to disable from the "additional sofware" or is there a different way to do this?

 

Thanks for your help.

Luca

Share this post


Link to post
Share on other sites

Hi Leon, following your instruction I have an error during the process, after the dkms built commad.

 

This is the result of the command:

luca@Dell-Precision-M4800:/usr/src/b43b1-6.30.223.141$ sudo dkms build -m b43b1 -v 6.30.223.141

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area....
make KERNELRELEASE=3.13.0-29-generic....(bad exit status: 2)
ERROR (dkms apport): binary package for b43b1: 6.30.223.141 not found
Error! Bad return status for module build on kernel: 3.13.0-29-generic (x86_64)
Consult /var/lib/dkms/b43b1/6.30.223.141/build/make.log for more information.
luca@Dell-Precision-M4800:/usr/src/b43b1-6.30.223.141$ 

It seems that the system does not find the binary packge, but I do not understand if it is looking in the wrong dyrectory.

Could you help me?

Luca

Share this post


Link to post
Share on other sites

Hi Leon!

Thank you for your clear instructions. I followed your guide an my basic WLAN works right now.
However I need to switch between multiple Access Points with my wlan card. Therefore I want to adjust the sensitivity value to optimize the timing for switching the AP.
In this context I miss certain functionalities using this driver:
 

  • The command "sudo iwconfig eth2 sens -60" does not seem to be supported and results in the following output:
    inc@os-22:~/robotics/scripts$ iwconfig eth2 sens -60
    Error for wireless request "Set Sensitivity" (8B08) :
        SET failed on device eth2 ; Operation not permitted.

 

 

  •  When I use the command "iwconfig eth2" (eth2 is the wlan) I  miss informations such as "Signal level" and "Link Quality" which are usually displayed:
    inc@os-22:/usr/src/b43b1-6.30.223.141/src$ iwconfig eth2
    eth2      IEEE 802.11abg  ESSID:"inc-5G"
          Mode:Managed  Frequency:5.18 GHz  Access Point: B0:C7:45:22:86:D8  
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

 

 

  • Interestingly the command "iwlist et2 scan" shows "Quality=51/70" and  "Signal level=-59 dBm"

 

So my questions are:

  •   Is this missing functionality a general issue of this driver or is more likely to be a problem with my wlan card?
  •   Do you have any suggestions to make this functions work?

Regards,

Mark

Share this post


Link to post
Share on other sites

Since its still a rather new card i would think its a driver issue - and by that try and track down the people behind the driver and ask them.

Share this post


Link to post
Share on other sites

×
×
  • Create New...