Jump to content

D620 SL 945GM no QE/CI [SOLVED]


Recommended Posts

My System info:

Dell Latitude d620

                 Mobile            945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub

                 Vendor ID:     8086

                 Dev ID:          27a0
                 Resolution:   1440 x 900


Problem encountered:

1. No QE/CI (no ripples when adding widgets, no welcome video on startup, no preview *even picture, and can't use vlc)

2. Wrong description in graphics/display info. 
Chipset model:        nVidia Graphics card
Type:                         GPU
Bus:                          built in
Vram (total):            128mb

        Vendor:                    Intel (0x8086)
Device ID:                0x27a2
ROM revision:         Silent Natit x86_64 v1.0.2


*Resolution is 1440 x 900 (no problem in resolution)



How did I install Snow Leopard?

1. Used boot loader by leppy700m 
    D620SLV1.ISO (Burned DVD)


2. Mounted retail copy of Snow Leopard 10.6.3 in my 16gb usb

3. Applied AppleBCM5751Ethernet.kext to get my ethernet working.

4. Post installation of D620SLV1.ISO so that i can boot without DVD

Methods I did to fix the problem ( no success )


1. Installed different 950gm kexts

2. Installed AppleIntellintegratedFramebuffer.kext 


3. Turned graphics enabler=no/yes in com.apple.Boot.plist



I've been searching but I can't really solve the problem. Can anyone help me as I really wanted the graphic acceleration. 

Probably can solve using DSDT.aml patch, but I don't understand how to do it. 


PS:* I will attach my dsdt (I'm not sure but I extracted it using the script by zhell the dsdt.sh.zip)
     ** I compress it to .rar



Link to comment
Share on other sites

  • Administrators

you probably need to put the original kexts you removed/replaced back then. also check your bios info for graphics as i see it shows as an nvidia for some reason. which if it really is GMA graphics it should not unless you have some injectors/kexts that don't belong.  d620 did come with an nvidia mobo also so you might be using the wrong boot pack/ dsdt.

Link to comment
Share on other sites

@Bronxteck: Yup, I've been mix and matching kext and there is a rebuild command where I can backup my original. My bios tells that I have

Video Controller = Intel 945GM Graphics


In addition, when I remove the natit.kext my system info shows GMA 950 (boots fine)

@rals2007: What do you mean sir? I used the DSDT.aml and put it in /Extra. It boots fine but the problem persists. 

I'm editing DSDT but I'm encountering syntax error when performing the guide below.



Link to comment
Share on other sites

^First of all thank you very much for your fast repond. But still no QE/CI

Tried with or without Natit.kext


What I have is AppleIntelGMA950.kext -
and                 AppleIntelIntegratedFrameBuffer.kext -



I also tried to extract my DSDT.aml again using the patch of Dr. Hurt (Paranoid if my first one is incorrect)

*Please see attach file
**When my external monitor is plugged, rotation = yes, mirror=no


Link to comment
Share on other sites

  • Create New...