Jump to content
KFP

ExpressCard USB 3.0 controllers

Recommended Posts

2 x USB3.0 ExpressCard working on X201 with Mavericks:

 

1) GMYLE BC628 34mm USB3.0 Adapter (ASMedia 1042 chipset)

41P2EU7IG9L.jpg

http://www.amazon.com/gp/product/B0045BLP1S/ref=oh_details_o04_s00_i00?ie=UTF8&psc=1

 

 

2) AKE BC398 54mm USB3.0 Adapter (NEC Renesas uPD720202 chipset)

 

51bQlaTulgL.jpg

 

 

http://www.amazon.com/gp/product/B008CEN02Q/ref=oh_details_o05_s00_i00?ie=UTF8&psc=1

 

 

GenericUSBXHCI.kext  supports both. you can install it from Source Project (search Google)

I got 2.5Gbps,  which is pretty good comparing with USB2.0 480Mbps. I am not sure, ExpressCard slot on X201 is version 1.0 or 2.0,  or above cards are designed as 1x ExpressCard.

 

I preferred ExpressCard 54  in X201,  it just fills in all gaps, it seems more steady to plugin and out USB device with it. and uPD720202 seems more stable for hot swapping than ASMedia 1042!

 

I read somewhere that ExpressCard can only reach 2.5Gbps as maximum bandwidth.  it does not matter the ExpressCard slot is 1x or 2x.  so the speed is correct.

 

Download my GenericUSBXHCI.kext: GenericUSBXHCI.kext.zip  (or http://yaodi.zzl.org/GenericUSBXHCI.kext.zip)

Share this post


Link to post
Share on other sites

I also found and tested NEC uPD720202 chip based Express/34 because Levono T410, T420 only have Express/34 slot.
post-4953-0-38112300-1461509228_thumb.jpg
It works same as Express/54 above, But only one issue to be aware,   it seems inside the card, it use some cheap D/A converter.  So if I connect a USB3 thumb drive. it is OK.  external USB3 hard drive which has its own 5V/2A adapter,   it is still OK.   But if it is bus-powered external Hard Drive. no way to get it running and connected.  The hard drive just cannot get enough power from the card to spin up (5400 rpm or 7200 rpm).  I tested 2 cards.  the same result.

Share this post


Link to post
Share on other sites

I would not consider the Lacie for the below reason:

Note: To operate this card with your Mac laptop, you will need a compatible Mac Pro, a LaCie USB 3.0 driver, as well as a LaCie USB 3.0 storage device. Please consult the LaCie website for information on which Mac laptops are compatible.

 

Which NEC card did you get, and does it need OSX drivers?

Share this post


Link to post
Share on other sites

This actually seems to work OOB (so to speak) with Generic USB3.0 kext (I used Rehabman's latest).

 

The BC628 certainly works up to Yosemite 10.10.5 under which it shows 2 x controllers in SysProfiler->USB:

BC268_USB3.0.jpg

 

Under El Capitan 10.11.4 (the version I run), no controllers get displayed in SysProfiler but the card does work with USB2.0 and USB3.0 devices (I tested with USB keys of both types).

GMYLE_BC628_10.11.4.jpg

 

NB: I bought a supposingly genuine GMYLE ExpressCard for peanuts on Amazon. Physical connection of USB devices is extremely poor and feels very loose. I can't say I'm impressed with the GMYLE adapter. I've bought another ExpressCard to test (NEC-based), hopefully it'll be of better quality.

 

Comparative BlackMagic tests (max values observed) on my SandyBridge Latitude E6220:

  • USB2.0 key in laptop built-in USB2.0 ports: 2.7MB/s Write, 12.3MB/s Read
  • USB2.0 key in GMYLE BC628 adapter: 2.9MB/s Write, 12.8MB/s Read
  • -----
  • USB3.0 key in laptop built-in USB2.0 ports: 8.1MB/s Write, 31.6MB/s Read
  • USB3.0 key in GMYLE BC628 adapter: 8.7MB/s Write, 62.4MB/s Read

Share this post


Link to post
Share on other sites

Received the AKE-looking NEC UPD720202-based ExpressCard I bought for even cheaper on the bay (from China)... If the GMYLE looked Ok, that one does not even look carefully built! Anyway, slotted it in and it worked OOB with the Generic XHCI kext installed.

NEC_USB3.0_Controller.jpg

NEC_UPD70202_EC34mm.jpg

 

Despite the extremely poor look of the card, my USB keys fit in my tighter and do not feel loose at all. In fact my USB3.0 key fitted in so well that on extracting it, the ExpressCard comes out with it!

 

I'm definitely advising to stay off cheap sales from on-line places. Genuine products from genuine brands (and probably genuine places) a must!

Share this post


Link to post
Share on other sites

Running El Capitan on an E6420. I bought a pretty generic NEC Renesas uPD720202 based ExpressCard and installed the Generic XHCI driver. The card is recognized. I see it under System Information in PCI as an XHCI ExpressCard and the icon appears on the menu bar. No XHCI controller shows under the USB section and the ports do not respond to having devices plugged into them. Of course, the card works fine in Windows.

 

I've looked at different guides about USB fixes for El Capitan but just came out confused. What do I need to do for El Capitan to enable those ports?

Share this post


Link to post
Share on other sites

Check that your Generic XHCI is properly installed and gets loaded at system startup. If it is, you should see the card in IOReg...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...