Jump to content

E6410 Clover Boot Problem


Quade321
 Share

Recommended Posts

Hello, I've been trying to get my Dell Latitude E6410 to boot using the Clover bootloader instead of Chameleon. However, when I try to load Clover, whether from my hard drive or a USB, it doesn't come up as a UEFI boot option in the one-time boot menu. I've tried to manually enter the path in the BIOS, BIOS Setup -> Boot Sequence -> UEFI -> Add Boot Option -> File Name: \EFI\BOOT\BOOTX64.efi but when I go to try to boot from the option I created, it just kicks back to the F12 one-time boot screen. 

 

I know I've properly configured Clover to at least show up as a UEFI boot option as I use it with my Gigabyte desktop. Is there something I'm doing wrong or is this just a problem with whatever BIOS dell decided to use in the E6410?

 

I am running the newest A16 BIOS (Which was updated by Dell just a few days ago)

I doubt it would matter but my hardware is as follows:

Service Tag: 57X71M1

CPU: i5-520M @ 2.4GHz

Graphics: NVS 3100 (GT218M)

 

Thank you. 

Link to comment
Share on other sites

I actually somewhat managed to work out what was going on with my laptop after reading more about UEFI and coming back to it after... whenever the last post I made in this thread was.

 

I'm still not sure why my laptop tends to not boot Clover UEFI normally, but I have been able to kinda force it to.

 

Whenever installing a UEFI OS (Like Ubuntu in my case), it adds its own boot option to the UEFI Boot List. In Ubuntu's case it's /EFI/ubuntu/shimx64.efi. And in the Latitude E6410 BIOS it lets you view the boot option and see what it's listed as.

 

So I looked at it the boot entry in my BIOS, and it said the filesystem it was looking at was HD(1,GPT, Then my drive's UUID), then it told me the path to the EFI file (/EFI/ubuntu/shimx64.efi). Okay, so I'll try to add my own boot option to see if I can make it boot Ubuntu myself to get a grip on what's happening. I add the option, and I pick my HDD from the list (it doesn't let you type it in yourself), and it fails to boot.

 

Now, what happened? Well, apparently when you add your own UEFI option in the BIOS, it adds the filesystem string incorrectly, causing any manual configuration to fail. So, good job Dell... 

 

Then, I realized, the BIOS sees shimx64.efi. I'll just rename Clover's BOOTX64.efi to shimx64.efi and put it in the same place. And it worked, then I used the Ubuntu boot option to load Clover and added Clover as a boot option. It added the proper CLOVERX64.efi boot entry to my BIOS. So, now I have some working ground. 

 

Then I was just gonna load the UEFI Shell from Clover and manually configure my UEFI options because why not? Well, Clover was acting a little strange and UEFI Shell wouldn't load. So I tried to load OS X from my flash drive, and that just failed all together, it didn't even bring up the OS X boot logo and my flash drive access indicator wasn't flickering. That makes me assume something is wrong and it's not even trying to load anything properly. 

 

So, that's where I'm stuck, I got Clover to load finally, but I can't get Clover to load OS X. This isn't really a request for help, just a note to others with an E6410 who would like to try to get OS X loading through UEFI themselves. 

 

Also, thanks to Bronxteck for trying to help me last month. 

Link to comment
Share on other sites

 Share

×
×
  • Create New...