Jump to content

D630, SL10.6.3, Dell 1505 wireless issue


lsidoomer
 Share

Recommended Posts

Hi all

 

I have a D630/Intel running SL10.6.3 where I replaced the Intel 3945 with a Dell 1505 card. The card indicates 4321rev3, while under Linux it shows up as 4328. Not sure which exactly it is.

 

Initially it seemed to work OK, but after a failed upgrade to 10.6.8 and 2 subsequent reinstalls, it seems to have a very flaky connection (on each of the 2 reinstalls), often dropping connection, not enough signal strength (where it should be good - right under the wireless router) and the works. All in all it is almost unusable.

 

I have tried the default IO80211Faimily, the hacked IO80211Family with the Broadcom43xx driver (kexts.com) even the BroadcomFix,kext. All of them have the same issue. I even tried the rebranding, and while it does show up as an apple branded card, it does fix the issue.

 

I have tried reseating the card, removing and putting back the connectors in an effort to see if there is some sort of loose connection, but no joy.

 

kextstat indicates that the 43xx driver is currently loaded. kextunload does not unload this driver, and removing the 80211family fails boot altogether.

 

I need help debugging this issue. How do I find dependencies? Which is the best kext for this card, and how do I ensure that gets loaded? How can I check the antenna gain - whether it is set to max or not?

 

Here's the ioreg output

 

 

| | +-o [email protected],1 <class IOPCIDevice, id 0x1000001c8, registered, matched, active, busy 0 (3335 ms), retain 10>

| | | +-o IOPCI2PCIBridge <class IOPCI2PCIBridge, id 0x100000215, registered, matched, active, busy 0 (3219 ms), retain 7>

| | | +-o [email protected] <class IOPCIDevice, id 0x1000001c9, registered, matched, active, busy 0 (3211 ms), retain 10>

| | | +-o AirPort_Brcm43xx <class AirPort_Brcm43xx, id 0x10000032e, registered, matched, active, busy 0 (433 ms), retain 8>

| | | +-o AirPort_Brcm43xxInterface <class AirPort_Brcm43xxInterface, id 0x100000330, registered, matched, active, busy 0 (430 ms), retain 10>

| | | +-o IONetworkStack <class IONetworkStack, id 0x10000034d, registered, matched, active, busy 0 (11 ms), retain 9>

| | | +-o IONetworkStackUserClient <class IONetworkStackUserClient, id 0x100000354, !registered, !matched, active, busy 0, retain 5>

Link to comment
Share on other sites

have you tried inverting the antenna wires?

Yep - black is connected to black and white to white currently. With the inversion, there was no signal at all.

 

Meanwhile, here's more info about the card:

 

en2:

Card Type: AirPort Extreme (0x14E4, 0x88)

Firmware Version: Broadcom BCM43xx 1.0 (5.10.91.26)

Locale: FCC

Country Code: US

Supported PHY Modes: 802.11 a/b/g/n

Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 36, 40, 44, 48, 52, 56, 60, 64, 149, 153, 157, 161, 165

 

So, the rebranding has worked. Is there a firmware update available?

Link to comment
Share on other sites

  • Administrators

the odd part is that it's on en2 why? usually it's on en0 or en1.... have you shut off all legacy ports and perifrials from bios like com/printer/modem ports? you might also have to shut down your ethernet card from bios. also you can try deleting your network devices and add them back in the networking prefpane or make a new location.

Link to comment
Share on other sites

the odd part is that it's on en2 why? usually it's on en0 or en1.... have you shut off all legacy ports and perifrials from bios like com/printer/modem ports? you might also have to shut down your ethernet card from bios. also you can try deleting your network devices and add them back in the networking prefpane or make a new location.

Bronxteck - thanks for the response.

 

I removed all items from network preferences and recreated the Airport. Earlier I had Airport2. Now i have Airport there. Still the wireless shows as en2 in "about this mac'. Do you think the en1/en2 business is the cause for the flaky connections? Is there a way to reset this to en1?

 

Thanks

Link to comment
Share on other sites

  • Administrators

shut off ethernet from bios as well as comm ports and printer ports and modem too see if that helps they take up valuable irq values that osx wants for other things. if not you might have to remove the ethernet not wifi kext in e/e and rebuild using current config in edp.

Link to comment
Share on other sites

shut off ethernet from bios as well as comm ports and printer ports and modem too see if that helps they take up valuable irq values that osx wants for other things. if not you might have to remove the ethernet not wifi kext in e/e and rebuild using current config in edp.

 

I need Ethernet, but will try shutting off others. I can try shutting off ethernet temporarily. Meanwhile, can I run EDP script after install? I have never been able to find out how to.

Link to comment
Share on other sites

 Share

×
×
  • Create New...