Jump to content

Dell D630/Intel X3100 - Not having much luck with Lion...


bbz_Ghost
 Share

Recommended Posts

Ok, I'm not "new" here, just a long time lurker finally able to get involved. I'll try to make this short and sweet (which means tl;dr people move on, this is a long post) since I - like so many others it seems, based on reading a few hundred posts over the past few days - am reaching that point of frustration with getting Lion installed and functional on this D630 of mine. I got the laptop about a week ago, with the following specs:

 

Core 2 Duo T7500 (2.2 GHz/4MB L2, not the factory CPU which was a T7250 so it's more powerful)

Hitachi 80GB 7200 rpm SATA II drive (factory drive, works fine)

4GB of DDR2 667 MHz RAM (factory was 2GB)

14.1" 1440x900 WXGA+ LCD panel (no damage, no dead pixels, it's beautiful)

Intel GMA X3100 (I may look for an Nvidia based mobo sometime but I know of the issues those had)

8x Philips DVD burner (factory drive, does quality testing which was surprising and works fine)

Broadcom BCM4312 802.11abg mini-PCI Wi-Fi card (should be Lion capable natively afaik)

Broadcom BCM5755M Gigabit NIC (should be Lion capable natively afaik)

9-cell battery with about 18% battery wear (measured with Battery Bar under Windows 7)

yada yada yada the rest is standard stuff as expected

 

Now, the beauty of this was that I found it at a pawn shop for $125, and it's nearly brand new I swear except for a tiny bit of wear on the top/lid (from where the previous owner carried it in his/her bare hands). And it came with the factory 90 watt power adapter (not the stock 65 watt) and a second 9-cell battery too (second battery has about 41% wear so it's not in the best shape but both batteries work fine for about 2+ hours).

 

Ok, so a fantastic amazing deal, a damned nice laptop, 2 9-cell batteries, and... it's still got 250 days of on-site Complete Care warranty available too. BONUS! :D Already transferred it to my name so I could toss it over my balcony and Dell would replace it, but that's not my intention, obviously.

 

My intention is to get Lion roaring on this, in a dual boot with Windows 7 Pro if possible, so I need to ask for some help 'cause I'm stumped.

 

At this moment I have Windows 7 Pro x64 installed (Dell OEM branded SLIC 2.1 version), I am currently using the "D630 BIOS" I found here at this forum that replaces the Dell logo with the Apple logo and changes the BIOS version from A17 to OSX (pretty cool thing, actually) without issues in Windows. I've got VMWare Workstation 7.14 installed and functional (actually purchased Workstation 7 last year when it available at a discount) and I unlocked VMWare to allow me to install Lion. I have OSX Lion that I purchased from iTunes (and I've gone through the motions to extract the InstallESD.dmg file) and converted it to a bootable ISO and then installed Lion in VMWare and it works great, albeit slow as expected.

 

Now, I've made about 20 attempts to get Lion fully functional as a native install on the D630 using a second hard drive (a full size 3.5" desktop Western Digital one that I've used to create an 8GB installer partition for Lion using that USB stick method; I have an 8GB USB stick ordered, will probably be here in a few days but I can get the external hard drive bootable just fine using myHack and the regular old USB stick method).

 

I know this is a lot of text so let me reiterate that last point emphatically:

 

I can get Lion's installer booted off that external drive and running, but I like so many other people making these attempts keep getting stuck with no video.

 

I know the installer is working, and I can visualize in my mind (I've installed OSx86 hundreds of times over the years, with great success) where I'm at when the screen goes black (the backlight is on, but the video isn't there since Lion and Snow Leopard have big issues with the X3100 it seems), and this is where I'm stuck. I'm not even sure how to use EDP 1.9 to be honest but I did "install" it to the external once it was ready to be put to use.

 

I've read hundreds of posts, made almost two dozen attempts so far and each time it's the same thing: no video.

 

I've found 3 dsdt.aml files that are supposedly for this exact Dell configuration: a D630 with Intel X3100 video at 1440x900 native resolution and I'm still dead in the water. I would love to get past this hump of not being able to see a damned thing if anyone is able to help.

 

I'd really love to get this up and running once and for all if anyone has any advice for me. Took two days to finally get it "installable" using the external drive (and yes I know a USB stick is more convenient but the installer boots up just fine, runs Chameleon, lets me see that things are working with the -v verbose boot, but once the grey Apple logo screen kicks in for a few seconds, then it goes black and the hard drive activity continues. I wait for a minute or two till nothing is happening, then press Enter and wham, a flurry of activity so I KNOW the installer is working, thankfully.

 

I just can't see anything - this "no video" black screen thing is a brick wall right now.

 

That's about it. I don't know how to resolve not being able to see anything. I've got a 17" 1440x900 external (VGA) monitor I've attached then tried to switch (with Fn+F8) and still no video, nothing.

 

Could sure use some advice 'cause I know other people have been able to get this particular laptop running Lion with near perfect compatibility - the fact that this configuration of mine is basically pure Broadcom is why I'm making this attempt at all for native operation. If it was using Intel wired and wireless I'd just use Lion in VMWare and be done with it, but... well, you all know the frustration of many attempts with no fruit born.

 

If anyone can help, I would greatly appreciate it.

 

Thanks, and have fun, always...

Link to comment
Share on other sites

  • Administrators

install the latest chameleon so far it's 1518 with chameleon wizard to your installer disk and it's modules folder. make sure graphics enabler is selected in org.chameleon.Boot.plist and you set your native res... make sure you have an extra folder on the installer drive with your dsdt.aml, org.chamelon.boot.plist, and proper smbios.plist for a macbook3,1. if you install and run edp on the external installer drive with edptool.command and build for your model it should supply all this, except the dsdt wich is intended for 1280x 800 screen... so replace it with your higher res. dsdt. keep the build simple no sleep/null no battery as you only need to install the os.

Link to comment
Share on other sites

bbz_Ghost,

 

Just my $0.02...

 

Bronxteck has a good thought on the BIOS. Maybe restore to the original Dell BIOS and try again.

 

Otherwise, are you sure it's up and alive? Can you ssh into it from another machine after the screen goes black? Sometimes I have to ssh into a failed install to get a clean reboot.

 

Also, are you running arch=i386? I'm still running Snow Leopard on my boxen but I'm sure there will come a day soon that I _have_ to upgrade. QE/CI is imperative to me, though (FCP and After Effects). I may actually go find an NVidia D630/830 for just this reason.

 

Keep plugging and keep us posted.

 

Mark

Link to comment
Share on other sites

 Share

×
×
  • Create New...