Jump to content

Precision M4400 sleep broken by update to 10.9.4


Recommended Posts

Greetings all and thanks for all your excellent work here!


I have succeeded with a 10.9.0 Mavericks install on my M4400 and eventually got sleep going but this was broken by the 10.9.4 Combo Update. Apple made a feature of improved sleep in promoting the update so obviously significant modifications have been made.  Have any fixes emerged for this yet?


My install method for 10.9.0:

myHack installation with the Extras folder from here: https://osxlatitude.com/index.php?/topic/2674-dell-e64006500m4400-mavericks-109-gm/?hl=m4400

(1/3 way down page)

Removed AppleACPIPlatform kext from the Extras folder (this kext is already in the Sys folder), then ran full myFix

Finally, changed the hibernate mode to 0.

Wake from sleep only ever worked by pressing the power button rather than from any keyboard keys.



Link to comment
Share on other sites

  • Administrators

Can you please post your /Extra folder? Personally, I've had no issue on any of my Latitude D or E Series, nor even on my desktops. Can't see why it would be different with your M4400. it's always worked OOB on those systems without any specific actions (except a DSDT patch maybe)


NB: Wake from keyboard or mouse has never been feasible on any Dell laptops I've hackinstoshed (I've done a few by now). This is more a desktop feature, configurable in BIOS.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...