Jump to content

Dell D830 (bios A17) Crestline Graphics installation problem (OS 10.7.2)


yuriym21
 Share

Recommended Posts

Hi, so I got myself dell d830 with crestline graphics(can support resolution of up to 1920 x 1200) with A17 and decided to make it into hackintosh.  I have tried installing many versions of mac on it, but decided to stick with OS X 10.7.2.  Now I tried mountain lion 10.8.5(using this method https://osxlatitude.com/index.php?/topic/2468-dell-latitude-d830-intel-gma-x3100-ml-with-full-qeci/) and it was working graphic wise, However it had problems with shutting down and I didn't have battery or sound support and when I ran EDP on it, it would stop booting.  So I decided to go with 10.7.2 instead since EDP supports it. 

 

Now with 10.7.2 Everything works beautifuly except for graphics.  I am stuck with the 1024x768 resolution.  Well, I had to use voodoo kext for sound so I guess it didn't work that beautifully. I have used the OSXLatitude's d830Low res, and d830 high res bootpacks when installing but that doesn't seem to work.  I tried running the system in 32 bit mode using (arch=i386 flag) but it always gets stuck at "resetting iocatalogue". Without the flag I can get it to boot after I remove  the appleIntelHD* and other video kexts. However, I am stuck with 1024x768 res.

 

I have included a DSDT file I extracted from my laptop.  If anyone can help me with this problem I would be really grateful. I have been trying to get it working by myself for over 2 weeks, and finally decided to humble myself and ask the pros for help.

 

Btw, I am using myHack 3.3 and 10.7.2 retail for installation.

 

I will be be downgrading to A15 to see if that solves the problem, hopefully it does. I will update this thread to let you know how that goes.

dsdt d830 Bios A17.zip

Link to comment
Share on other sites

  • Administrators

Whatever the OS X version you go for, you can only run a Crestline laptop in 32bit kernel mode. There's no graphics support for the GMA X3100 graphics chip in 64bit mode. If you're running Lion 10.7.2 in 64bit default mode, that'll be the reason why you're not getting any graphics support.

 

Make sure you use our bootpack and if EDP fails, we'll work something out to make it work. I think it's fairly safe for you to go back to ML 10.8.5 (if that's what you prefer) and we'll get those features to work.

 

No need to downgrade BIOS, it'll not make any difference.

Link to comment
Share on other sites

Ok, thanks.  I will go with 10.7.2,

 

Here is a little update.  I tried the D830 HiRes bootpack.  It installed fine, but when I tried to boot, it gave me an ACPI path not found, and hung on the ACPI LPC warning.  I tried going to single user mode to try to remove the video kexts but it freezes when I move the files.  If I first check disk, it freezes on "checking catalog".  I am booting with arch=i386 bootflag.  If I try booting without any flags, it hangs at "added 32bit to lower".

I tried booting with the -f flag, but it stops at the LPC warning.

 

Now I am going to try lowres pack, to see if that works.

 

edit: ok I installed the lowres pack.  Without any flags or removing any kexts, it stays at "resetting iocatalogue".  Keyboard works so its not frozen.  It just stays on that point.  I am using the bootloader that myHack 3.3.1 installed on. After running myFix, I am getting sound assertion failures and "failed to locate SMC driver".  Oh, and there is a timeout on AppleIntelCPUPowerManagement.  Hope this is enough.

 

edit 2:I am attaching a screen cap.  I am not using any boot flags in this one.  Sometimes it would go into resetting iocatalogue sometimes it won't.  The system isn't frozen as I can press caps lock and it would turn the LED on.  Oh, and I used this bootpack http://www.osxlatitude.com/packs/Dell/Penryn/Dell_Latitude_D830_Intel/Dell_Latitude_D830_Intel-lion.zip

 

I checked the type of cpu I have and it seems to be T7250, 2.0Ghz 800 Mhz fsb speed.

post-64359-0-43180100-1410809873_thumb.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...