Jump to content

Dell D620 Broadcom LAN 57xx Not Working


creed205
 Share

Recommended Posts

Hi Guys,

 

I have a 10.6.6 install on my D620 with Intel graphics. Everything is working from what I can see except for the wired LAN connection. I am able to use wireless but I like to have backup with the wired when needed. I tried a couple of IONetworkingFamily.kexts and an AppleBCM5751Ethernet.kext but when using that IONetworking... it caused the wireless to stop working.

 

Is there a way to get the LAN working?

 

Thanks!

Link to comment
Share on other sites

Mine doesn't work either, so your not alone in this but my backup is another wireless ;)

 

OMG I just struck gold. I used the attached file and installed it with Kext-Helper and it works on my D620 under 10.6.6. Hopefully it will keep working as I upgrade.

 

Can you try this and let me know if it works? I would like to have it included in the future updates if it's solid.

AppleBCM5751Ethernet.kext.zip

Link to comment
Share on other sites

Hey Guys,

 

I see we have 4 downloads. Did we have any luck with my driver? Just to let you know, my Broadcom device ID is 14e4:1600. If yours is not the same it might not work. My question is, are all the D620s the same? Thanks for trying guys.

Link to comment
Share on other sites

abbreviation for Extra/Extensions folder..

 

Ahh, you know what? I tried it in my E/E and it wouldn't work. I had to use the KEXT Helper (which of course puts it in System/Library/Extentions) and it worked there. What is the difference between the 2 really? I thought that it should work in either location.

Link to comment
Share on other sites

 Share

×
×
  • Create New...