Jump to content

Dell e5420 HD 3000 full qe/ci


Recommended Posts


I installed 10.9.0 Mavericks on Dell e5420 and can't get full qe/ci. 

My specs: 

2520m with Intel HD 3000 graphics

6GB Ram 

2x SSD drive with 2hd Caddy

1600x900 resolution


The problem is that when I remove all graphics kexts - can get desktop, but have no qe/ci and instead of got flickering.

Tried many kext (AppleIntelSNBGraphicsFB) but any of them didn't work (got blank screen after boot).  


If someone have that model and got HDMI Audio + Full qe/ci - please attach in answer.

I'm really tired with config and lot of options , bot flags etc. Tried in any way with no luck.  

It will be really nice to get some help...

Link to comment
Share on other sites

  • Moderators

I assume you don't have a patched DSDT working?

Download MACIasl or DPCIManager and extract a raw DSDT, attach it here and I'll patch it for you.

Also you'll have to put back all the graphics kexts if you want full QE/CI working.


Try booting with GraphicsEnabler=Yes EnableDualLink=Yes

Link to comment
Share on other sites

Thank you for reply. 

I don't know why but now I have 1024x768 instead of 1600x900 when boot to OS. 

Could you tell me which kexts are necessary to run HD3000? 

Earlier I run with ...Azuri, ...Capri and AppleIntelSNBGraphicsFB but had many glitches , artefacts and system was unstable. 


So I done backup of graphics kext with chameleon and checked option "don't drop DSDT". Now is the situation. 


(I can't attach DSDT - got error You aren't permitted to upload this kind of file) 

Link to comment
Share on other sites

Thank you! 

You made my day... 


Now I have another problem. 

When I set resolution to 1600x900 - have glitches and random graphical artifacts - they are huge and show up relatively quick.


When I set 1344x756 - they are smaller and show up after some time.


I think so maybe it's something with NVRAM or/and something with full buffer.

and maybe it's proper hd 3000 kext 


What I can do with that  ? 

Link to comment
Share on other sites

I'm not sure which metod I used. 

Many times I have changed bootloader and installation. 

I installed with Myhack and with tonycrap ...beast 

I think that artifacts may be related with RAM. 

I have 2 sticks 2 + 4. Removed 2gb and so far nothing bad happened. 


I updated system to 10.9.5 with no problem instead HDMI audio. 

Have VoodoHDA kext and no audio output with hdmi. 

Is there any way to fix ? 


Once more thank you for help... 

Link to comment
Share on other sites

  • Create New...