Jump to content

Triple Boot experiences


gewitterknecht
 Share

Recommended Posts

This is not going to be a detailed guide, but I wanted to share my experiences how I got triple boot working on my D430.

Also, this might be not the most effective way to do it - but it worked ;)

 

- I prepared an USB stick with the premade SL image from this great site.

- Successfully booted from the usb stick; partitioned the SSD with GUID partition table using the OS X disk utility application: 3 partitions, the first for Windows (FAT), the second for OS X (HFS Journaled, not case sensitive) and the third for Linux (also FAT for now)

- Installed OS X on the second partition /dev/sda2 - this also creates the EFI partition as /dev/sda1 so things change and now we have: /dev/sda1 EFI partition, sda2 Windows, sda3 OS X currently installing and sda4 Linux

- Booted again from the USB stick but chose the new installation on the internal SSD in Chameleon

- In OS X installed EDP 1.9.1, ran edptool, installed the kexts etc, installed the included Chameleon and updated to 10.6.8

- Now I had a working OS X installation with Chameleon bootloader - on to Linux

- Actually I'm an ArchLinux user, but for the sake of simplicity I used Ubuntu for now because I can easily have a working live USB stick and can install it in a short time without much configuration hassle (and everything works out of the box - nice).

- Prepared Ubuntu live USB stick (I used Unetbootin), booted from it, was offended by Unity, and started the installer.

- Chose manual partition and mountpoint config and chose /dev/sda4 for / (only one partition, which is debatable, but I personally don't really see the need to have /boot /home /var and so on dedicated partitions), also no dedicated swap partition, again I don't need it, 2 GB RAM is more than enough for me and Linux

- The Ubuntu installer wanted to install GRUB2 so I gave it /dev/sda4 for GRUB2, it probably complained about blocklists but that doesn't matter

- Rebooted and Chameleon saw the Linux partition, which brought me to grub and from there to my new Ubuntu installation (you can also boot OS X from there)

- Now comes the sorcery - installed GPT fdisk (gdisk) and used it to create a hybrid MBR

- Rebooted into the Windows 7 installation media (I again used an USB stick)

- Chose the custom install option, I had to reformat the partition I dedicated to Windows

- Installed Windows successfully to that partition but now the laptop booted directly into Windows

- Now I rebooted from the OS X USB stick again, chose the OS X partition on the SSD, booted into OS X and reinstalled Chameleon with edptool

- Then I had the Chameleon bootloader available again, but unfortunately Windows didn't boot anymore due to the device inaccessible error.

- I can't recall the exact steps, but after tinkering with which partition was active and the BCD it booted successfully again (IIRC booting from the Windows installation media, invoking cmd and bootrec.exe /fixboot and /rebuildbcd did the trick)

- For good measure I booted into Ubuntu and reinstalled GRUB2 to /dev/sda4 (using the --force because it would complain), to have the option to boot into Ubuntu, OS X and Windows from there. Probably you could also just remove it, I didn't try though.

 

And that's how I spent the last two days, I hope this was not too confusing :)

 

Cheers

Link to comment
Share on other sites

have you tried using chameleon boot0md instead of boot0hfs you have the option in chameleon wizard works better for multi-boot environments i have lion and 7 on my d430 using that.

No I didn't try that. It works perfectly right now. "Never touch a running system" as the saying goes ;)

Link to comment
Share on other sites

 Share

×
×
  • Create New...