Jump to content

[SOLVED] Anyone tried the dell latitude inspiron el capitan guide on e7440? no battery status?


Recommended Posts

Hi! first of all, thanx for providing the guide for installing El Capitan on Dell e7440, I'm referring to the below link...



I tried it on my e7440 i5 system, with firmware A08, following the instructions, provided, and install seems to work no problem. Even though I realized that the ACPIBatteryManager.kext kext for power/battery control was included as part of the package, and copied into the EFI partition per the instructions, somehow I don't see the battery indicator.


When I go to System Preferences --> Energy Saver --> Check "Show battery status in menu bar", the battery icon in the menu bar flashes, and dissapears, and the "checked box" to show the battery status in the menu bar becomes unchecked automatically.


Is there anything that I should check or anything I might have missed? I copied the bootpack for the e7440 into /EFI_Clover/Clover  as indicated, and renamed the  EFI_Clover to EFI.



Link to comment
Share on other sites

Hi! thanks Jake 4 pointing out the update! Downloaded that, and replaced the older version of ACPIBatteryManager.kext I had in the EFI folder with ACPIBatteryManager.kext v1.60.4, and the battery icon in the menu bar came back!




Just a couple comments regarding my preference for running OSX on the e7440...

As a  "best practice" I always have an image of a working copy of the drive available, in case I need to re-image de OSX partition in the even of something not working right, using SuperDuper, since it's freely available for personal use for imaging the drive, and you only need to pay/buy, if you want to use its advance feature, which I don't. So having the install USB is very handy for those cases!


Also, on my e7440 (uefi) , I have Win10 running on the internal 2.5" HD, and OSX on the mSATA. In my experience, Win10 won't install if the mSATA is present, so had to remove the mSATA, install Win10, then put back the mSATA (with OSX already installed), and set the uefi boot device to the mSATA drive on the firmware page (the one that shows up when pressing F2 when the DELL logo appears when powering up the system).

Link to comment
Share on other sites

  • Create New...