Jump to content

(Solved) E6430u missing key on german keyboard (Mavericks)


Recommended Posts

Hi everybody,

I have 2 laptops both running with Mav 10.9.5:
   (1) dell D630 c2d, bios a19, nvidia 4gb 800Mhz, 1440x900, GERMAN keyboard
   (2) dell e6430u i7, bios A06, HD4000 8gb 1600mhz, 1600x900, GERMAN keyboard (this one I have an issue with)
Installation was done based on the myhack method and using laptop specific Extras provided in this forum. Thanks for great support and fantastic forum here, by the way.
First of all my problem is not related to keyboard mapping. Solving the key mapping problem by using a tool like UKELELE is not what I am looking for. Here is why…
Everything that I need seems to be working as it should except for one “missing key†on the e6430u german keyboard (kbd). I guess my e6430u hackintosh does not recognize the kbd physical layout properly.  Whatever kbd layout I select in kbd “input sources†window OSX does not show the “<“ key that is between the left shift and the “Y†key on my german kbd at all. 
Interestingly, on my D630 all keys are shown on the “input sources†layout picture and all keys are working. When I boot my e6430u in DOS or FreeDOS all keys are present and working.
I am not an IT specialist, but I believe OSX does not load the 105 key but 104 key layout. (?)
Last but not least, my D630 came with german kbd from the factory, whereas the e6430u came originally with US kdb that I swapped by German kbd.
In this picture below you can see how the kbd layout is being shown in "Input Sources" on my D630:
In this picture below you can see how the kbd layout is being shown in "Input Sources" on my e6430u:
Hope somebody can help me out here to figure out where the problem is and how to fix it.  Thanks a lot.
Link to comment
Share on other sites

  • Administrators

you might have to try different keyboard/trackpad kexts. do both machines have the same kexts installed? you can also try swapping the keyboard kexts out. it is located inside the plugins folder of the ps2 kext. make sure to rebuild caches after.

Link to comment
Share on other sites

I am assuming you mean those *PS2*.kext file that is located in /Extra/Extensions!?!?

Below is a list of kexts that I have in my e6430u /Extra/Extensions...


[email protected] 3 root  wheel  102 May  4  2014 ACPIBatteryManager.kext

[email protected] 3 root  wheel  102 Apr 21  2012 AppleACPIPlatform.kext

[email protected] 3 root  wheel  102 Jul  3  2014 AppleHDA.kext

[email protected] 3 root  wheel  102 Oct  5  2013 AppleIntelCPUPowerManagement.kext

[email protected] 3 root  wheel  102 Sep 25  2013 AppleIntelE1000e.kext

[email protected] 3 root  wheel  102 Feb  7  2014 AppleIntelFramebufferCapri.kext

[email protected] 3 root  wheel  102 Sep 19  2013 AppleKextExcludeList.kext

[email protected] 3 root  wheel  102 Jan 21  2013 ApplePS2Controller.kext

[email protected] 3 root  wheel  102 Jun 21  2013 AppleSmartBatteryManager.kext

[email protected] 3 root  wheel  102 Jul 21  2013 DisableTurboBoostBattery.kext

[email protected] 3 root  wheel  102 Jul  8  2013 FakeSMC.kext

[email protected] 3 root  wheel  102 Oct 30  2013 GenericUSBXHCI.kext

[email protected] 3 root  wheel  102 Oct 23  2013 Patched_10.7_AppleRTC.kext

[email protected] 3 root  wheel  102 Feb 11  2014 VoodooPS2Controller.kext

[email protected] 3 root  wheel  102 Nov 24  2012 lspcidrv.kext

Just realized that I have 2 of *PS*.kext files there. I doubt I need both. Which one should I replace and which remove? My D630 does not have "VoodooPS2Controller.kext", but just the ApplePS2*.kext.
How do I do replace the file(s)? Just overwrite it and that is it? No need to run myhack or something?
Link to comment
Share on other sites

Missing key problem is solved. :) Thanks, Bronx!

I tried 2 ways. Prior to running fix in myhack I swapped:

  (1) "ApplePS2Keyboard.kext" in "ApplePS2Controller.kext/PlugIns" by the one I had for D630 and deleted VoodooPS2Controller.kext from /Extra/Exte*.

  (2) "VoodooPS2Keyboard.kext" in "VoodooPS2Controller.kext/Plugins" by "ApplePS2Keyboard.kext" for D630 and deleted ApplePS2Controller.kext  from /Extra/Exte*.

The second way did not work at all. It screwed up the kernel so the machine won't start any more (kernel panic or something).


I am wondering what "VoodooPS2Controller.kext" does more or better than "ApplePS2Controller.kext" for my E6430?

Link to comment
Share on other sites

  • Administrators

hard to tell as the ps2 kext's have gotten highly fragmented over the years the kext names might be the same but they support totally different hardware. many coders have had there contributions and branches and usually it is to there benefit hardware wise. as a coder you can only thoroughly test the hardware you have on hand best. so basically using your example if the coder was in a country that uses 104 key keyboard he will most likely only code for that since thats what he has. if he had a 105 lets say then same. 

Link to comment
Share on other sites


  • Create New...