Jump to content

Dell Latitude E6420


philznow
 Share

Recommended Posts

Hi guys and gals just thought i would give my experiance with the Latitude E6420.

 

i have been using unifail install method with a 10.7.2 retail, building the external bootable usb easy as pie, install's perfectly after install you need boot with the usb pluged in so you have a boot menu after you have selected the drive that you have installed Lion on you then need the multifail 4.1 package installer to install chimera (chameleon, stolen and rebranded) or you can use chameleon bootloader up to you but install nullcpu and fakesmc kext's to boot otherwise it throws up a panic.

after install i used easybeast install and most hardware detected

what is working

Processor: i7 2720qm (detected all cores)

Ram 8GB

Hard drive only working in ahci

Audio/Mic install Voodoo Hda 2.7.3 but only works with dsdt but we will get to that later

Graphics detects 1024x768

Battery/Adapter Voodoo Battery not working with dsdt

Usb works out the box but can cause panic and crashing so use iousb rollback and it starts working perfectly

webcam not working

 

right now is the bit which im scratching my head on and need some help with the dsdt

if you use this dsdt ThinkPad T420 the graphics work perfectly hdmi out works vga out works but it causes cpu overheating

stops voodoo battery from working and stops the fn key from working so have to turn down brightness from display settings so not helpful at all i tried to edit the dsdt with no luck what i want to do it strip out the nvidia part of the dsdt and just test that first but i dont have the know how.

 

i will do some more testing today and report back

Link to comment
Share on other sites

  • Administrators

firstly you should be using your own dsdt for your model dell not lenovo... there are programs to extract this but you have to boot without the dsdt file if not will not be a clean dump of your machin... you can try a program called dsdt editor and patcher... google for it. then you can do the patch you want to do with graphics...

Link to comment
Share on other sites

i have the same notebook and have most stuff is running now, only sleep mode and multitouch trackpad is not working.

 

can anybody help me getting the ALPS Trackpad working?

i tried several kexts and nothing is working. the voodoops2 kext from slice with ALPmultitouch is recognizing the trackpad as an trackpad but it is not working. if i touch the trackpad it is moving around and clicking all the time.

Link to comment
Share on other sites

 Share

×
×
  • Create New...