Jump to content

[Solved] DW5550 not working in El Capitan


Erfan
 Share

Recommended Posts

I got Problem with DW5550 on El Capitan 10.11.2 on my Dell Latitude E6220

My DW5550 was working well on Lion, ML, Mav and also Yosemite but on El, i can't find it on network preference so i used that kext patch
It's added on wwan tab but it almost not showing in network preferences

Thanks

https://osxlatitude.com/index.php?/topic/6556-wwan-using-ericsson-f5521gw-hp-hs2340-hspa-dell-dw5550-in-os-x/

post-3834-0-90842100-1452355095_thumb.png

post-3834-0-32319600-1452355117_thumb.png

Link to comment
Share on other sites

  • Administrators

I guess you actually meant that it never appears in the Network PrefPane, even when trying to add the interface manually.
 
To me, your module has not properly registered as a WWAN module. Whilst it's listed in the SysProfiler->WWAN section, I was expecting to see a lot more information.
 
I'd double check your patch if I were you. Or maybe it no longer works in EC... I'll check it out.

Link to comment
Share on other sites

thanks for your fast reply 

and sorry for my bad english

 

i just added this code on "/System/Library/Extensions/CellPhoneHelper.kext/Contents/Info.plist"

please help me to find what i missed

 

		<key>0x413c/0x818d Dell Wireless HSDPA Modem (DW5550)</key>
		<dict>
			<key>CFBundleIdentifier</key>
			<string>com.apple.driver.AppleUSBHostMergeProperties</string>
			<key>IOClass</key>
			<string>AppleUSBHostMergeProperties</string>
			<key>IOProviderClass</key>
			<string>IOUSBHostDevice</string>
			<key>IOProviderMergeProperties</key>
			<dict>
				<key>DeviceModemOverrides</key>
				<dict>
					<key>AccessPointName</key>
					<string>Obtain From Service Provider</string>
					<key>ConnectionPersonality</key>
					<string>Novatel GSM Personality</string>
					<key>ConnectionScript</key>
					<string>WWAN.ccl</string>
					<key>DeviceContextID</key>
					<string>1</string>
					<key>DeviceModel</key>
					<string>GSM</string>
					<key>DeviceVendor</key>
					<string>Novatel Wireless Inc.</string>
				</dict>
				<key>DevicePPPOverrides</key>
				<dict>
					<key>LCPMTU</key>
					<integer>1450</integer>
				</dict>
				<key>ExpressCardCantWake</key>
				<true/>
				<key>InfoCommands</key>
				<dict>
					<key>ATCommands</key>
					<dict>
						<key>DirectoryNumber</key>
						<string>+cnum</string>
						<key>ICCID</key>
						<string>$nwiccid?</string>
						<key>IMEI</key>
						<string>+cgsn</string>
						<key>IMSI</key>
						<string>+cimi</string>
						<key>Manufacturer</key>
						<string>+cgmi</string>
						<key>Model</key>
						<string>+cgmm</string>
						<key>ModemSW</key>
						<string>+cgmr</string>
						<key>Serial#</key>
						<string>+gsn</string>
					</dict>
					<key>HiddenProperties</key>
					<dict>
						<key>CommandPortBaseName</key>
						<string>wwan</string>
						<key>ControlPortBaseName</key>
						<string>wwanCNTL</string>
						<key>DataPortBaseName</key>
						<string>wwan</string>
						<key>InterfaceDriver</key>
						<string>AppleWWANSupport1</string>
						<key>StatusType</key>
						<string>NovatelGSM</string>
					</dict>
				</dict>
				<key>Initializing</key>
				<true/>
				<key>InterfaceMapping</key>
				<dict>
					<key>0</key>
					<dict>
						<key>name</key>
						<string>wwan</string>
					</dict>
					<key>1</key>
					<dict>
						<key>name</key>
						<string>wwanCNTL</string>
					</dict>
				</dict>
				<key>WWAN</key>
				<true/>
			</dict>
			<key>bcdDevice</key>
			<integer>0</integer>
			<key>idProduct</key>
			<integer>33165</integer>
			<key>idVendor</key>
			<integer>16700</integer>
		</dict>

 

on this code i just changed pid , vid from "Novatel Wireless HSDPA Modem (XU870)" for DW5550

post-3834-0-47592900-1452371237_thumb.png

Link to comment
Share on other sites

  • Administrators

Ha, it would appear you did not patch the kext properly. You need to rigorously follow the instructions as detailed in the specific thread for DW5550 module. Hint: DW5550 is an Ericsson module, not a Novatel one, nor a DW5520...

 

I've verified myself and had no issue using my HP hs2340 as a WWAN module in 10.11.2:

DW5550_10.11.2_#1.jpg

DW5550_10.11.2_#2.jpg

Link to comment
Share on other sites

OK i edit it but still nothing happened

 

<key>0x413c/0x818d Dell Wireless HSDPA Modem (DW5550)</key>
<dict>
<key>CFBundleIdentifier</key>
<string>com.apple.driver.AppleUSBMergeNub</string>
<key>IOClass</key>
<string>AppleUSBMergeNub</string>
<key>IOProviderClass</key>
<string>IOUSBDevice</string>
<key>IOProviderMergeProperties</key>
<dict>
<key>DeviceModemOverrides</key>
<dict>
<key>AccessPointName</key>
<string>Obtain From Service Provider</string>
<key>ConnectionPersonality</key>
<string>Sony Ericsson GPRS</string>
<key>ConnectionScript</key>
<string>Generic GPRS.ccl</string>
<key>DeviceContextID</key>
<string>1</string>
<key>DeviceModel</key>
<string>GPRS (GSM/3G)</string>
<key>DeviceVendor</key>
<string>Sony Ericsson</string>
</dict>
<key>DevicePPPOverrides</key>
<dict>
<key>LCPMTU</key>
<integer>1450</integer>
</dict>
<key>InfoCommands</key>
<dict>
<key>ATCommands</key>
<dict>
<key>DirectoryNumber</key>
<string>+cnum</string>
<key>IMEI</key>
<string>+cgsn</string>
<key>IMSI</key>
<string>+cimi</string>
<key>Manufacturer</key>
<string>+cgmi</string>
<key>Model</key>
<string>+cgmm</string>
<key>ModemSW</key>
<string>+cgmr</string>
</dict>
<key>HiddenProperties</key>
<dict>
<key>CommandPortBaseName</key>
<string>wwan</string>
<key>ControlPortBaseName</key>
<string>wwan</string>
<key>DataPortBaseName</key>
<string>wwan</string>
<key>InterfaceDriver</key>
<string>AppleUSBCDC</string>
<key>StatusType</key>
<string>CellPhoneGSM</string>
</dict>
</dict>
<key>Initializing</key>
<true/>
<key>InterfaceMapping</key>
<dict>
<key>2</key>
<string>wwan</string>
</dict>
<key>WWAN</key>
<true/>
</dict>
<key>bcdDevice</key>
<integer>0</integer>
<key>idProduct</key>
<integer>33165</integer>
<key>idVendor</key>
<integer>16700</integer>
</dict>

 

actually it's not working as usb modem

my interfaces :

post-3834-0-57615600-1452410174_thumb.png

Link to comment
Share on other sites

  • Administrators

I've updated the guide to avoid any confusion since there clearly was some with El Capitan. Please follow the revised instructions to the letter:

For [...] Yosemite and El Capitan, proceed as follows:

  • Remove the 3 WWAN modems listed in Network Preferences
  • Make a backup of vanilla CellPhoneHelper kext found in /S/L/E
  • Make a copy of CellPhoneHelper.kext from /S/L/E to your desktop
  • Open up the Desktop kext and browse through to the Contents folder to patch the Info plist as detailed below
  • Once your plist has been updated, move the patched kext from your Desktop to /S/L/E and replace the original kext
  • Repair permissions, rebuild cache and reboot

The patch basically consists of a pasted copy of the Sony Ericsson W350 entry, modified with the Ericsson FF5521gw, HP hs2340 or Dell DW5550 PCI device ids (entered in decimal values) and the Sony Ericsson reference for Device Vendor.
 
It seems you took the shortcut of copying/pasting the code I had previously published as an example in the thread. That applied to Mav/Yos and will not work in EC... I've modified the guide to avoid this.
 
Basically, you need to start from the W350 entry provided in CellPhoneHelper v1.4.0 of EC. You should notice the code differs a little between the EC version of the kext and earlier OS X versions; that's why the patch you made was not working.

Link to comment
Share on other sites

 Share

×
×
  • Create New...