Jump to content

[Solved] [E5x20] Clover not detecting new Yosemite install when booting from HDD


Recommended Posts

Got Yosemite installed with everything working on my E5420. Swapped wifi for a DW1510 and used an E5x20 bootpack I found on the forum here.


The system boots fine using Clover from my install USB, but not from the hard drive. I have copied the EFI folder from the USB to the FAT32 formatted ESP on my hard drive. Went into BIOS (version A14), switched boot mode to UEFI, and added boot entry for Cloverx64.efi. upon reboot, the laptop boots into Clover just fine, even using the theme i selected, but no bootable partitions are detected. I have Hfsplus.efi in the drivers64UEFI folder, and the whole EFI/Clover folder structure is identical to the one on my USB, which works.


Any ideas what could be causing this issue?

Link to comment
Share on other sites

Found the solution in another thread.



I could add entries for UEFI boot with an EFI partition formatted with FAT16 ! Incredible, the last Dell firmware do not recognise FAT32 !

You need to reformat the EFI partition : sudo newfs_msdos -v EFI -F 16 /dev/rdiskXs1

Reboot OSX, mount EFI , copy EFI folder into. Reboot again and hit F2 to enter bios setup. Add an entry into UEFI boot menu (name OSX or anything, path to EFI/BOOT/BOOTX64.EFI.


What's weird is on my E5420, I was able to add the boot entry even with the ESP being FAT32, but I guess it doesn't load Clover fully due to this bug. Reformatted the ESP to FAT16 and it works now.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...