Jump to content
PayPal donations: [email protected] ×
sahilsaid

[SOLVED] Dell Latitude E6420 El Capitan USB Ports not working

Recommended Posts

I have El capitan installed with windows 10 (dual boot) on my Latitude E6420. Everything seems to be working fine except that when I use OSX Capitan, none of the USB ports work. 

 

I tried connecting my external hard drive as well as a USB stick (2.0) and nothing is detected. I tried looking into "Disk Utility" too but no luck there either.

 

I connected my android phone and that is receiving the power but again, it doesn't get picked up by the "android file transfer" software. 

 

I followed the Latitude E6xxx installation guide with clover. I used E6220 bootpack from post #2 of this guide.

 

Does anybody know what I should do to fix this problem?

Share this post


Link to post
Share on other sites

Did you change the SMBios to anything but MBP8,2?

Switch back if you did otherwise the USB injector won't work...hard coded.

Share this post


Link to post
Share on other sites

Absolutely spot on!
 
I replaced config.plist in EFI partition from E6220.zip folder and regenerated ssdt.aml and replaced that too in EFI partition. Restarted the machine and all is working now.
 
Thanks.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...