Jump to content

Acer Aspire E15 E5 573G 52G3


marcelodonnici
 Share

Recommended Posts

Hello OSX Latitude. I have an ACER ASPIRE E5 573G 52G3 with cpu intel broadwell i5 5200U, Graphics intel HD 5500/Nvidia 940M with 2gb VRAM, 8gb RAM, 1Tb HDD.

I'm stuck trying to install OS X El Capitan on it. I managed to reach the installer but it won't detect my HDD. I tried then connecting the HDD as an external HDD (via USB) and it installed flawlessly! but when I rebooted I got the "still waiting for root device" error message.
I'm attaching my EFI folder for your review.

Can someone please help? I've been trying to fix this issue for over three weeks (literally non stop) and still no solution :-(

Thank you in advance.

EFI.zip

Link to comment
Share on other sites

  • Administrators

Check that  your HDD mode is set to AHCI in the BIOS settings. OS X does not usually support modes such as RAID. One other thing you may try when you obtain the "waiting for root device" is unplug then replug your USB installer key.

Link to comment
Share on other sites

Hi, thanks for the reply. My Bios can't be changed, however, I learned that AHCI is set by default, so thankfully, this isn't the issue. When I received the error message "waiting for root device" was when I installed the HDD again internally.

Here's the issues I have:

1) If I attempt to install OS X El Capitan via bootable USB, the installer won't detect internal HDD. (It will only detect it if I remove it and plug it in as an external HDD via USB)

2) Once I managed to install OS X and then install the HDD back to its original place, it will give the error message "still waiting for root device".

 

I learned also on other forums it might be due to SSDT patching, but I'm not very technical, so I'm not sure how to do that.

Please let me know what else can be done. Thanks in advance!

Link to comment
Share on other sites

 Share

×
×
  • Create New...