Jump to content

M4800 BlackScreen on eDP QHD+


opoeta
 Share

Recommended Posts

Good afternoon and happy new year I have an M4800 with a K2100, my model has no built-in graphics. Only the K2100, it uses eDP, and I can not image without using nvidia_disable = 1, my screen is 3200x1800. On the hdmi cable it works normally, however on the screen of the notebook always it is black screen.

Link to comment
Share on other sites

  • Moderators

Try this patch by theDarkvoid

# Run the following command in order to patch IOKit in order to disable CheckTimingWithRange
sudo perl -i.bak -pe 's|\xB8\x01\x00\x00\x00\xF6\xC1\x01\x0F\x85|\x33\xC0\x90\x90\x90\x90\x90\x90\x90\xE9|sg' /System/Library/Frameworks/IOKit.framework/Versions/Current/IOKit
sudo codesign -f -s - /System/Library/Frameworks/IOKit.framework/Versions/Current/IOKit
Link to comment
Share on other sites

 Share

×
×
  • Create New...